UVA - 11461-Square Numbers

Posted Persistent.

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了UVA - 11461-Square Numbers相关的知识,希望对你有一定的参考价值。

11461 - Square Numbers

Time limit: 1.000 seconds 

A square number is an integer number whose square root is also an integer. For example 1, 4, 81 are some square numbers. Given two numbers a and b you will have to ?nd out how many square numbers are there between a and b (inclusive).
Input

The input ?le contains at most 201 lines of inputs. Each line contains two integers a and b (0 < a ≤ b ≤ 100000). Input is terminated by a line containing two zeroes. This line should not be processed.
Output
For each line of input produce one line of output. This line contains an integer which denotes how many square numbers are there between a and b (inclusive).
Sample Input
1 4

1 10

0 0
Sample Output
2

3

题意就是a-b(包括a,b)的范围内有多少个平方数。

代码:

#include<iostream>
#include<math.h>
using namespace std;
typedef long long ll;
int main(){
    ll n,m,ans,cnt,i;
    while(cin>>n>>m){
        if(n==0&&m==0)break;
            ans=0;
        for(i=n;i<=m;i++){
            cnt=sqrt(i);
        if(cnt*cnt==i)
            ans++;
        }
        cout<<ans<<endl;
    }
    return 0;
}

 

交题的时候,用C语言交了10几次,卡我格式错误,都不知道看一下用什么交的吗?(╯‵□′)╯︵┻━┻

C语言代码,就改一下输入输出。。。

代码:

#include<stdio.h>
#include<math.h>
int main(){
    int n,m,ans,cnt,i;
    while(~scanf("%d%d",&n,&m)){
        if(n==0&&m==0)break;
        ans=0;
        for(i=n;i<=m;i++){
            cnt=sqrt(i);
        if(cnt*cnt==i)
            ans++;
        }
        printf("%d\n",ans);
    }
    return 0;
}

==

 

以上是关于UVA - 11461-Square Numbers的主要内容,如果未能解决你的问题,请参考以下文章

UVA - 10591 Happy Number

Uva 136-丑数 ugly number

UVA 1650 Number String

UVA - 10706 Number Sequence

UVA 10909 - Lucky Number(树状数组)

题解 UVA1185 Big Number