E - 钱币兑换问题

Posted 徐义宝

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了E - 钱币兑换问题相关的知识,希望对你有一定的参考价值。

 
 
 
在一个国家仅有1分,2分,3分硬币,将钱N兑换成硬币有很多种兑法。请你编程序计算出共有多少种兑法

Input每行只有一个正整数N,N小于32768。

Output对应每个输入,输出兑换方法数。

Sample Input

2934
12553

Sample Output

718831
13137761


题解:首先都会想到循环,但是只要控制不好都会超时,我的想法是,将循环次数控制到最小;
首先大循环以三分为基础,剩下就是分配给二分和一分,因为有一分,所以肯定可以分完,
只要求出两分的有几种就可以,剩下的一分肯定能补齐;代码:
#include<iostream>
#include<cmath>
#include<cstring>
#include<string>
#include<cstdio>
using namespace std;
const int MS = 32768/2;


int main(){


 int n;
 while(cin>>n){
    int cnt=0;
    int MA=n/3;
    for(int i=0;i<=MA;i++){

        int MZ=(n-i*3);

            cnt+=(MZ/2+1);


    }

    cout<<cnt<<endl;
 }




}

 





#include<iostream>#include<cmath>#include<cstring>#include<string>#include<cstdio>usingnamespacestd; constint MS = 32768/2; int main(){ int n; while(cin>>n){ int cnt=0; int MA=n/3; for(int i=0;i<=MA;i++){ int MZ=(n-i*3); cnt+=(MZ/2+1); } cout<<cnt<<endl; } }

以上是关于E - 钱币兑换问题的主要内容,如果未能解决你的问题,请参考以下文章

钱币兑换问题

HDU 1284 钱币兑换问题

Problem1284 钱币兑换问题

钱币兑换问题(杭电1284)(母函数)

HDU1284 钱币兑换问题完全背包

钱币兑换问题---hdu1284(完全背包)