HDU4638:Group(线段树离线处理)

Posted yxysuanfa

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了HDU4638:Group(线段树离线处理)相关的知识,希望对你有一定的参考价值。

Problem Description
There are n men ,every man has an ID(1..n).their ID is unique. Whose ID is i and i-1 are friends, Whose ID is i and i+1 are friends. These n men stand in line. Now we select an interval of men to make some group. K men in a group can create K*K value. The value of an interval is sum of these value of groups. The people of same group‘s id must be continuous. Now we chose an interval of men and want to know there should be how many groups so the value of interval is max.
 

Input
First line is T indicate the case number.
For each case first line is n, m(1<=n ,m<=100000) indicate there are n men and m query.
Then a line have n number indicate the ID of men from left to right.
Next m line each line has two number L,R(1<=L<=R<=n),mean we want to know the answer of [L,R].
 

Output
For every query output a number indicate there should be how many group so that the sum of value is max.
 

Sample Input
1 5 2 3 1 2 5 4 1 5 2 4
 

Sample Output
1 2
题意:给出一个数组。每次查询l,r。看区间内能分成几个连续的数列
思路:离线处理全部查询
#include <iostream>
#include <stdio.h>
#include <string.h>
#include <stack>
#include <queue>
#include <map>
#include <set>
#include <vector>
#include <math.h>
#include <bitset>
#include <algorithm>
#include <climits>
using namespace std;

#define ls 2*i
#define rs 2*i+1
#define UP(i,x,y) for(i=x;i<=y;i++)
#define DOWN(i,x,y) for(i=x;i>=y;i--)
#define MEM(a,x) memset(a,x,sizeof(a))
#define W(a) while(a)
#define gcd(a,b) __gcd(a,b)
#define LL long long
#define N 100005
#define MOD 1000000007
#define INF 0x3f3f3f3f
#define EXP 1e-8
#define rank rank1
const int mod = 10007;

struct node
{
    int l,r,val;
} a[N*4],s[N];

int num[N],pos[N],vis[N],ans[N];
int n,m;

int cmp(node a,node b)
{
    return a.r<b.r;
}

void build(int l,int r,int i)
{
    a[i].l = l;
    a[i].r = r;
    a[i].val = 0;
    if(l==r) return;
    int mid = (l+r)/2;
    build(l,mid,ls);
    build(mid+1,r,rs);
}

void updata(int i,int pos,int v)
{
    a[i].val+=v;
    if(a[i].l==a[i].r) return;
    int mid = (a[i].l+a[i].r)/2;
    if(pos<=mid) updata(ls,pos,v);
    else updata(rs,pos,v);
}

int query(int l,int r,int i)
{
    if(a[i].l==l&&a[i].r==r)
    {
        return a[i].val;
    }
    int mid = (a[i].l+a[i].r)/2;
    if(r<=mid) return query(l,r,ls);
    if(l>mid) return query(l,r,rs);
    return query(l,mid,ls)+query(mid+1,r,rs);
}

int main()
{
    int t,i,j,k,cnt;
    scanf("%d",&t);
    while(t--)
    {
        MEM(vis,0);
        scanf("%d%d",&n,&m);
        for(i = 1; i<=n; i++)
        {
            scanf("%d",&num[i]);
            pos[num[i]] = i;
        }
        for(i = 1; i<=m; i++)
        {
            scanf("%d%d",&s[i].l,&s[i].r);
            s[i].val = i;
        }
        sort(s+1,s+1+m,cmp);
        build(1,n,1);
        cnt = 1;
        for(i = 1; i<=n&&cnt<=m; i++)
        {
            updata(1,i,1);
            vis[num[i]]=1;
            if(vis[num[i]-1]) updata(1,pos[num[i]-1],-1);
            if(vis[num[i]+1]) updata(1,pos[num[i]+1],-1);
            while(s[cnt].r==i&&cnt<=m)
            {
                ans[s[cnt].val] = query(s[cnt].l,s[cnt].r,1);
                cnt++;
            }
        }
        for(i = 1; i<=m; i++)
            printf("%d\n",ans[i]);
    }

    return 0;
}




以上是关于HDU4638:Group(线段树离线处理)的主要内容,如果未能解决你的问题,请参考以下文章

HDU 4630 No Pain No Game(线段树离线处理)

hdu 4638 Group

One Occurrence 线段树离线维护最小值

51Nod 1571 最近等对(线段树离线查询)

Codeforces Round #207 (Div. 1) A. Knight Tournament (线段树离线)

hdu 4417 Super Mario(主席树)