HDU 1040.As Easy As A+B排序如题(水!水!水!)8月24

Posted yangykaifa

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了HDU 1040.As Easy As A+B排序如题(水!水!水!)8月24相关的知识,希望对你有一定的参考价值。

As Easy As A+B

Problem Description
These days, I am thinking about a question, how can I get a problem as easy as A+B? It is fairly difficulty to do such a thing. Of course, I got it after many waking nights.
Give you some integers, your task is to sort these number ascending (升序).
You should know how easy the problem is now!
Good luck!
 

Input
Input contains multiple test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow. Each test case contains an integer N (1<=N<=1000 the number of integers to be sorted) and then N integers follow in the same line. 
It is guarantied that all integers are in the range of 32-int.
 

Output
For each case, print the sorting result, and one line one case.
 

Sample Input
2 3 2 1 3 9 1 4 7 2 5 8 3 6 9
 

Sample Output
1 2 3 1 2 3 4 5 6 7 8 9
水题不解释:

#include<cstdio>
#include<algorithm>
using namespace std;
int main(){
    int t,n;
    scanf("%d",&t);
    while(t--){
        scanf("%d",&n);
        int f[1010];
        for(int i=0;i<n;i++)
            scanf("%d",&f[i]);
        sort(f,f+n);
        for(int i=0;i<n;i++){
            if(i!=0) printf(" ");
            printf("%d",f[i]);
        }
        printf("\n");
    }
    return 0;
}

技术分享














以上是关于HDU 1040.As Easy As A+B排序如题(水!水!水!)8月24的主要内容,如果未能解决你的问题,请参考以下文章

HDU1040: As Easy As A+B

HDU 1040 As Easy As A+B (排序。。。水题)

HDU 1040.As Easy As A+B排序如题(水!水!水!)8月24

So Easy! HDU - 4565

hdu4565 So Easy!(矩阵快速幂)

HDU4565 So Easy! 矩阵高速幂外加数学