hdoj-1312-Red and Black

Posted mthoutai

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了hdoj-1312-Red and Black相关的知识,希望对你有一定的参考价值。

Red and Black

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 12433 Accepted Submission(s): 7726


Problem Description
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can‘t move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.

Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

‘.‘ - a black tile
‘#‘ - a red tile
‘@‘ - a man on a black tile(appears exactly once in a data set)

Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input
6 9 ....#. .....# ...... ...... ...... ...... ...... #@...# .#..#. 11 9 .#......... .#.#######. .#.#.....#. .#.#.###.#. .#.#[email protected]#.#. .#.#####.#. .#.......#. .#########. ........... 11 6 ..#..#..#.. ..#..#..#.. ..#..#..### ..#..#..#@. ..#..#..#.. ..#..#..#.. 7 7 ..#.#.. ..#.#.. ###.### [email protected] ###.### ..#.#.. ..#.#.. 0 0

Sample Output
45 59 6 13

Source
php?

field=problem&key=Asia+2004%2C+Ehime+%28Japan%29%2C+Japan+Domestic&source=1&searchmode=source">Asia 2004, Ehime (Japan), Japan Domestic


Recommend
Eddy | We have carefully selected several similar problems for you: 1016 1010 1372 1242 1253

#include<stdio.h>
#include<string.h>
char map[22][22];
int  dd[22][22];
int  n,m;
void DP(int i,int j,int &res){
	if(i<=0||i>n||j<0||j>=m) return ;
	if(map[i][j]=='#') return;
	if(dd[i][j]==0&&(map[i][j]=='.'||map[i][j]=='@')) {
		dd[i][j]=1;
		res++;
		DP(i-1,j,res);DP(i+1,j,res);
		DP(i,j-1,res);DP(i,j+1,res);
	}
}
int main(){
	while(scanf("%d %d",&m,&n),n||m){
		memset(map,0,sizeof(map));
		memset(dd,0,sizeof(dd));
		int i,j,res,num=0;int tx,ty;

		for(i=1;i<=n;++i){
	            scanf("%s",map[i]);		
		}
		for(i=1;i<=n;++i){
			for(j=0;j<m;++j)
			  if(map[i][j]=='@') 
			    tx=i,ty=j;
		}
		//printf("%d====%d\n",tx,ty);;
		res=0;
		DP(tx,ty,res);
		printf("%d\n",res);
	}
	return 0;
}


以上是关于hdoj-1312-Red and Black的主要内容,如果未能解决你的问题,请参考以下文章

(DFS)hdoj1312-Red and Black

POJ 1979 Red and Black (简单dfs)

Red and Black

[dfs] [FloodFill] POJ1979 Red And Black

1312 Red and Black

Red and Black(dfs水)