Hdu 1219 AC Me

Posted 寂地沉

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了Hdu 1219 AC Me相关的知识,希望对你有一定的参考价值。

AC Me

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 18543    Accepted Submission(s): 7836

Problem Description

Ignatius is doing his homework now. The teacher gives him some articles and asks him to tell how many times each letter appears.

It‘s really easy, isn‘t it? So come on and AC ME.

 

 

Input

Each article consists of just one line, and all the letters are in lowercase. You just have to count the number of each letter, so do not pay attention to other characters. The length of article is at most 100000. Process to the end of file.

Note: the problem has multi-cases, and you may use "while(gets(buf)){...}" to process to the end of file.

 

 

Output

For each article, you have to tell how many times each letter appears. The output format is like "X:N".

Output a blank line after each test case. More details in sample output.

 

 

Sample Input

hello, this is my first acm contest!

work hard for hdu acm.

 

 

Sample Output

a:1

b:0

c:2

d:0

e:2

f:1

g:0

h:2

i:3

j:0

k:0

l:2

m:2

n:1

o:2

p:0

q:0

r:1

s:4

t:4

u:0

v:0

w:0

x:0

y:1

z:0

 

a:2

b:0

c:1

d:2

e:0

f:1

g:0

h:2

i:0

j:0

k:1

l:0

m:1

n:0

o:2

p:0

q:0

r:3

s:0

t:0

u:1

v:0

w:1

x:0

y:0

z:0

#include<stdio.h>
#include<string.h>char x[100001];
int ans[26];
int count=0;
int main()
{
 int len,i;
    while(gets(x))
    {
       memset(ans,0,sizeof(ans));
       len=strlen(x);
    for(i=0;i<len;i++)
         {
          if(x[i]>=‘a‘ && x[i]<=‘z‘)
             ans[(int)x[i]-‘a‘]++;
         }
    for(i=0;i<26;i++)
       printf("%c:%d\n",i+‘a‘,ans[i]);
    printf("\n");     
    }
 return 0; 
}

  

以上是关于Hdu 1219 AC Me的主要内容,如果未能解决你的问题,请参考以下文章

(HDU)1219 -- AC Me

HDU - 1219 AC Me(超级水题)

HDU3247 Resource Archiver(AC自动机+BFS+DP)

HDU4057 Rescue the Rabbit(AC自动机+状压DP)

POJ - 2778 ~ HDU - 2243 AC自动机+矩阵快速幂

HDU2457 DNA repair(AC自动机+DP)