ZOJ 2750 Idiomatic Phrases Game

Posted 寂地沉

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了ZOJ 2750 Idiomatic Phrases Game相关的知识,希望对你有一定的参考价值。

Idiomatic Phrases Game

Tom is playing a game called Idiomatic Phrases Game. An idiom consists of several Chinese characters and has a certain meaning. This game will give Tom two idioms. He should build a list of idioms and the list starts and ends with the two given idioms. For every two adjacent idioms, the last Chinese character of the former idiom should be the same as the first character of the latter one. For each time, Tom has a dictionary that he must pick idioms from and each idiom in the dictionary has a value indicates how long Tom will take to find the next proper idiom in the final list. Now you are asked to write a program to compute the shortest time Tom will take by giving you the idiom dictionary.

Input

The input consists of several test cases. Each test case contains an idiom dictionary. The dictionary is started by an integer N (0 < N < 1000) in one line. The following is N lines. Each line contains an integer T (the time Tom will take to work out) and an idiom. One idiom consists of several Chinese characters (at least 3) and one Chinese character consists of four hex digit (i.e., 0 to 9 and A to F). Note that the first and last idioms in the dictionary are the source and target idioms in the game. The input ends up with a case that N = 0. Do not process this case.

Output

One line for each case. Output an integer indicating the shortest time Tome will take. If the list can not be built, please output -1.

Sample Input

5

5 12345978ABCD2341

5 23415608ACBD3412

7 34125678AEFD4123

15 23415673ACC34123

4 41235673FBCD2156

2

20 12345678ABCD

30 DCBF5432167D

0

Sample Output

17

-1

#include<stdio.h>
#include<string.h>
#define INF 0x3fffffff
#define maxn 1000
struct idiom
{
	char front[5],back[5];
	int T;
};
idiom dic[maxn];
int edge[maxn][maxn];
int dist[maxn];
int S[maxn];
int N;
int main()
{
	int i,j,k;
	char s[100];
	int len;
	while(scanf("%d",&N)!=EOF,N)
	{
		for(k=0;k<N;k++)
		{
			scanf("%d%s",&dic[k].T,s);
			len=strlen(s);
			for(i=0,j=len-1;i<4;i++,j--)
			{
				dic[k].front[i]=s[i];
				dic[k].back[3-i]=s[j];
			}
			dic[k].front[4]=dic[k].back[4]=‘\0‘;
		}
		for(i=0;i<N;i++)
		{
			for(j=0;j<N;j++)
			{
				edge[i][j]=INF;
				if(i==j)continue;
				if(strcmp(dic[i].back,dic[j].front)==0)
					edge[i][j]=dic[i].T;
			}
		}
		for(i=0;i<N;i++)
		{
			dist[i]=edge[0][i];S[i]=0;
		}
		S[0]=1;dist[0]=0;
		for(i=0;i<N-1;i++)
		{
			int min=INF,u=0;
			for(j=0;j<N;j++)
			{
				if(!S[j]&&dist[j]<min)
				{
					u=j;min=dist[j];
				}
			}
			S[u]=1;
			for(k=0;k<N;k++)
			{
				if(!S[k]&&edge[u][k]<INF&&dist[u]+edge[u][k]<dist[k])
					dist[k]=dist[u]+edge[u][k];
			}
		}
		if(dist[N-1]==INF)printf("-1\n");
		else printf("%d\n",dist[N-1]);
	}
	return 0;
}

  

以上是关于ZOJ 2750 Idiomatic Phrases Game的主要内容,如果未能解决你的问题,请参考以下文章

ZOJ-2750 Idiomatic Phrases Game---Dijk最短路

Idiomatic Phrases Game 成语接龙SPFA+map

Idiomatic Phrases Game(图论最短路)

HDU 1546 Idiomatic Phrases Game 求助!help!!!

让 Ensembles Idiomatic OSX App 与 iCloud 同步

搜索语义优化1:match_phrase和match的区别