POJ 2955?Brackets

Posted 寂地沉

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了POJ 2955?Brackets相关的知识,希望对你有一定的参考价值。

Brackets

Description

We give the following inductive definition of a “regular brackets” sequence:

  • the empty sequence is a regular brackets sequence,
  • if s is a regular brackets sequence, then (s) and [s] are regular brackets sequences, and
  • if a and b are regular brackets sequences, then ab is a regular brackets sequence.
  • no other sequence is a regular brackets sequence

For instance, all of the following character sequences are regular brackets sequences:

(), [], (()), ()[], ()[()]

while the following character sequences are not:

(, ], )(, ([)], ([(]

Given a brackets sequence of characters a1a2 … an, your goal is to find the length of the longest regular brackets sequence that is a subsequence of s. That is, you wish to find the largest m such that for indices i1i2, …, im where 1 ≤ i1 < i2 < … < im ≤ nai1ai2 … aim is a regular brackets sequence.

Given the initial sequence ([([]])], the longest regular brackets subsequence is [([])].

Input

The input test file will contain multiple test cases. Each input test case consists of a single line containing only the characters (, ), [, and ]; each input test will have length between 1 and 100, inclusive. The end-of-file is marked by a line containing the word “end” and should not be processed.

Output

For each input case, the program should print the length of the longest possible regular brackets subsequence on a single line.

Sample Input

((()))

()()()

([]])

)[)(

([][][)

end

Sample Output

6

6

4

0

6

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
char s[102];
int dp[102][102];
int main()
{
    int i, j, k, x;
    while(gets(s)!=NULL)
    {
        if(s[0]==‘e‘)break;
        memset(dp,0,sizeof(dp));
        int len= strlen(s);
        for(k=1;k<len;k++) //表示区间长度,从0-len更新
        {
            for(i=0,j=k;j<len;i++,j++)
            {
                if(s[i]==‘(‘&&s[j]==‘)‘||s[i]==‘[‘&&s[j]==‘]‘) //匹配
                    dp[i][j]=dp[i+1][j-1]+2;
                for(x=i;x<j;x++)   //区间最值合并
                    dp[i][j]=max(dp[i][j],dp[i][x]+dp[x+1][j]);
            }
        }
        printf("%d\n",dp[0][len-1]);
    }
    return 0;
}

  

以上是关于POJ 2955?Brackets的主要内容,如果未能解决你的问题,请参考以下文章

POJ2955 Brackets

POJ 2955 - Brackets - [区间DP]

Brackets POJ - 2955 (区间dp)

POJ 2955 Brackets(区间DP)题解

POJ 2955 Brackets

POJ 2955?Brackets