POJ-1003-hangover
Posted |瑾诺学长|
tags:
篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了POJ-1003-hangover相关的知识,希望对你有一定的参考价值。
Description
How far can you make a stack of cards overhang a table? If you have one card, you can create a maximum overhang of half a card length. (We‘re assuming that the cards must be perpendicular to the table.) With two cards you can make the top card overhang the bottom one by half a card length, and the bottom one overhang the table by a third of a card length, for a total maximum overhang of 1/2 + 1/3 = 5/6 card lengths. In general you can make n cards overhang by 1/2 + 1/3 + 1/4 + ... + 1/(n + 1) card lengths, where the top card overhangs the second by 1/2, the second overhangs tha third by 1/3, the third overhangs the fourth by 1/4, etc., and the bottom card overhangs the table by 1/(n + 1). This is illustrated in the figure below.
Input
Output
Sample Input
1.00 3.71 0.04 5.19 0.00
Sample Output
3 card(s) 61 card(s) 1 card(s) 273 card(s)
题目大意:
给定卡的长度,如图放置,求至少放几张就会超过卡片的长度;
#include<iostream>
using namespace std;
int main()
{
double len;
while(cin>>len)
{ int sum=0;
double s=0;
if(len==0)break;
for(int i=2;;i++)
{
s+=1.0/i;
sum++;
if(s>len)
{
break;
}
}
cout<<sum<<" card(s)"<<endl;
}
return 0;
}
以上是关于POJ-1003-hangover的主要内容,如果未能解决你的问题,请参考以下文章