HDU 2844 Coins (多重背包计数 空间换时间)

Posted liguangsunls

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了HDU 2844 Coins (多重背包计数 空间换时间)相关的知识,希望对你有一定的参考价值。


Coins

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 8999    Accepted Submission(s): 3623

Problem Description
Whuacmers use coins.They have coins of value A1,A2,A3...An Silverland dollar. One day Hibix opened purse and found there were some coins. He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the price would not more than m.But he didn‘t know the exact price of the watch.

You are to write a program which reads n,m,A1,A2,A3...An and C1,C2,C3...Cn corresponding to the number of Tony‘s coins of value A1,A2,A3...An then calculate how many prices(form 1 to m) Tony can pay use these coins.
 
Input
The input contains several test cases. The first line of each test case contains two integers n(1 ≤ n ≤ 100),m(m ≤ 100000).The second line contains 2n integers, denoting A1,A2,A3...An,C1,C2,C3...Cn (1 ≤ Ai ≤ 100000,1 ≤ Ci ≤ 1000). The last test case is followed by two zeros.
 
Output
For each test case output the answer on a single line.
 
Sample Input
3 10 1 2 4 2 1 1 2 5 1 4 2 1 0 0
 
Sample Output
8 4
 
Source
2009 Multi-University Training Contest 3 - Host by WHU

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=2844

题目大意:n种数,每一个数的值为ai,有ci个,求能组成多少个不大于m的不同的数字
 
题目分析:这题的数据量实在感人。三层循环(枚举种类,枚举数值。枚举个数)肯定超时,要想办法减去一层循环,细致分析能够发现个数的那层循环能够省掉,代价是耗费很多其他的空间。开一个cnt数组记录当前第i种使用了多少个,其他两层循环不变,然后就是普通的背包计数问题


#include <cstdio>
#include <cstring>
int const MAXM = 1e5 + 5;
int const MAXN = 1e2 + 5;
bool dp[MAXM];
int cnt[MAXM];
int a[MAXN], c[MAXN];

int  main()
{
    int n, m;
    while(scanf("%d %d", &n, &m) != EOF && (n + m))
    {
        memset(dp, false, sizeof(dp));
        for(int i = 1; i <= n; i ++)
            scanf("%d", &a[i]);
        for(int i = 1; i <= n; i ++)
            scanf("%d", &c[i]);
        dp[0] = true;
        int ans = 0;
        for(int i = 1; i <= n; i ++)
        {
            memset(cnt, 0, sizeof(cnt));
            for(int s = a[i]; s <= m; s ++)
            {
                if(!dp[s] && dp[s - a[i]] && cnt[s - a[i]] < c[i])
                {
                    dp[s] = true;
                    ans ++;
                    cnt[s] = cnt[s - a[i]] + 1;
                }
            }
        }
        printf("%d\n", ans);
    }
}


以上是关于HDU 2844 Coins (多重背包计数 空间换时间)的主要内容,如果未能解决你的问题,请参考以下文章

背包专题 D - Coins hdu2844多重背包

hdu2844Coins(多重背包模板)

HDU - 2844 Coins(多重背包+完全背包)

HDU 2844 Coins (多重背包问题DP)

hdu2844 Coins 多重背包

hdu2844 Coins