杭电1102 Constructing Roads

Posted mfmdaoyou

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了杭电1102 Constructing Roads相关的知识,希望对你有一定的参考价值。

Constructing Roads

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 13518    Accepted Submission(s): 5128


Problem Description
There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected.

We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.

Input
The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village i and village j.

Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.

Output
You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum.

Sample Input
3 0 990 692 990 0 179 692 179 0 1 1 2

Sample Output
179

 

这道题也是用的最小生成树做的

代码:

#include<stdio.h>
#include<string.h>
#define INF 1 << 30
int map[101][101] ;
int dis[101] ;
int used[101] ;
void prim( int N )

 for(int k = 1 ; k <= N ; k++)
 {
  dis[k] = map[1][k] ;
  used[k] = 0 ;
 }
 int sum = 0 ;
 for(int i = 1 ; i <= N ; i++ )
 {
  int min = INF ;
  int c = 0 ;
  for(int j = 1 ; j <= N ; j++ )
  {
   if(!used[j] && dis[j] < min )
   {
    min = dis[j] ;
    c = j ;
   }
  }
  used[c] = 1 ;
  for(j = 1 ; j <= N ; j++)
  {
   if(!used[j] && dis[j] > map[c][j])
    dis[j] = map[c][j] ;
  }
 }

 for(i = 1 ; i <= N ; i++)
  sum += dis[i] ;
 printf("%d\n", sum);
}
int main()
{
 int N = 0 ;
 while(~scanf("%d" , &N))
 {
     memset(map , 0 , sizeof(map) ) ;
  for(int i = 1 ; i <= N ; i++)
  {
   for(int j = 1 ; j <= N ; j++)
   {
    scanf("%d" , &map[i][j]) ;
   }
  }
  int Q = 0 ;
  scanf("%d" , &Q) ;
  int x = 0 , y = 0 ;
        for( int m = 1 ; m <= Q ; m++ )
  {
   scanf("%d%d" , &x , &y ) ;
   map[x][y] = map[y][x] = 0 ;//已经建好的树不用再建了
  }
  prim( N ) ;
 }
 return 0 ;
}

 

以上是关于杭电1102 Constructing Roads的主要内容,如果未能解决你的问题,请参考以下文章

Hdoj 1102.Constructing Roads 题解

HDU 1102 Constructing Roads(kruskal)

HDU-1102 Constructing Roads ( 最小生成树 )

HDU1102--Constructing Roads(最小生成树)

hdu 1102 Constructing Roads (Prim算法)

HDU 1102 Constructing Roads