openjudge 4116:拯救行动

Posted 小时のblog

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了openjudge 4116:拯救行动相关的知识,希望对你有一定的参考价值。

传送门

 

总时间限制: 
1000ms
 
内存限制: 
65536kB
描述

公主被恶人抓走,被关押在牢房的某个地方。牢房用N*M (N, M <= 200)的矩阵来表示。矩阵中的每项可以代表道路(@)、墙壁(#)、和守卫(x)。 
英勇的骑士(r)决定孤身一人去拯救公主(a)。我们假设拯救成功的表示是“骑士到达了公主所在的位置”。由于在通往公主所在位置的道路中可能遇到守卫,骑士一旦遇到守卫,必须杀死守卫才能继续前进。 
现假设骑士可以向上、下、左、右四个方向移动,每移动一个位置需要1个单位时间,杀死一个守卫需要花费额外的1个单位时间。同时假设骑士足够强壮,有能力杀死所有的守卫。

给定牢房矩阵,公主、骑士和守卫在矩阵中的位置,请你计算拯救行动成功需要花费最短时间。

输入
第一行为一个整数S,表示输入的数据的组数(多组输入)
随后有S组数据,每组数据按如下格式输入 
1、两个整数代表N和M, (N, M <= 200). 
2、随后N行,每行有M个字符。"@"代表道路,"a"代表公主,"r"代表骑士,"x"代表守卫, "#"代表墙壁。
输出
如果拯救行动成功,输出一个整数,表示行动的最短时间。
如果不可能成功,输出"Impossible"
样例输入
2
7 8
#@#####@
#@a#@@[email protected]
#@@#[email protected]@@
@@#@@#@#
#@@@##@@
@#@@@@@@
@@@@@@@@ 
13 40
@[email protected]@##[email protected]#[email protected]#xxxx##@#[email protected]@@#x#@#x#@@[email protected]#@x
xx###[email protected]#@@##[email protected]@@#@[email protected]@#[email protected]@@#[email protected]#[email protected]@[email protected]
#@x#@x#x#@@##@@x#@xx#[email protected]@x##@@@#@[email protected]@[email protected]
@##[email protected]@@x#xx#@@#xxxx#@@[email protected]@#@[email protected]@@[email protected]#@#[email protected]#
@#xxxxx##@@x##[email protected]@@#[email protected]####@@@x#x##@#@
#xxx#@#x##[email protected]@#[email protected]@@[email protected]#@#[email protected]#####
#[email protected]#@[email protected]@@@##@x#xx#[email protected]#xx#@#####x#@x
xx##@#@x##x##x#@x#@a#[email protected]##@#@##[email protected]#@@[email protected]
x#x#@[email protected]#x#@##@[email protected]#[email protected]##x##xx#@#[email protected]@
#[email protected]@#@###x##[email protected]#@@#@@[email protected]@@[email protected]@@@##@@[email protected]@x
x#[email protected]###@xxx#@#x#@@###@#@##@x#@[email protected]#@@#@@
#@#[email protected]#x#x###@[email protected]@xxx####[email protected]##@x####xx#@x
#x#@x#x######@@#[email protected]#xxxx#[email protected]@@#xx#x#####@
样例输出
13
7

【思路】
广搜+优先队列维护
错误:结构体忘记写比较函数,优先队列里定义的是Node
【code】
#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<queue>
using namespace std;
int endx,endy,strx,stry,t,n,m;
char map[201][201];
int dx[4]={0,0,1,-1},
    dy[4]={1,-1,0,0};
int b[201][201];
int ans;
struct node
{
    int x,y,val;
    bool operator < (const node a) const
    {
        return a.val<val;
     } 
};
priority_queue<node>q;

int bfs(int x,int y)
{
    
    while(!q.empty())
    {
        node now=q.top();q.pop();
        for(int i=0;i<4;i++)
        {
            int xx=now.x+dx[i],yy=now.y+dy[i];
            if(xx>=0&&xx<n&&yy>=0&&yy<m&&!b[xx][yy])
            {
                if(map[xx][yy]==x)
                {
                    b[xx][yy]=1;
                    q.push((node){xx,yy,now.val+2}); 
                }
                if(map[xx][yy]==@)
                {
                    b[xx][yy]=1;
                    q.push((node){xx,yy,now.val+1}); 
                }
                if(xx==endx&&yy==endy)
                {
                    ans=now.val+1;
                    return 1;    
                }
            }
        }
    }
    return 0;
}
int main()
{
    scanf("%d",&t);
    while(t--)
    {
        memset(b,0,sizeof(b));
        scanf("%d%d",&n,&m);
        while(!q.empty())q.pop();
        for(int i=0;i<n;i++)
        {
            scanf("%s",map[i]);
            for(int j=0;j<m;j++)
            {
               if(map[i][j]==r)
                {
                    strx=i;stry=j;
                }
                if(map[i][j]==a)
                {
                    endx=i;endy=j;
                }    
            }    
        }
        q.push((node){strx,stry,0});
        if(bfs(strx,stry))printf("%d\n",ans);
        else printf("Impossible\n");
    }
    return 0;
}

 

以上是关于openjudge 4116:拯救行动的主要内容,如果未能解决你的问题,请参考以下文章

STL优先队列priority_queue详解+OpenJudge-4980拯救行动

C++-拯救行动 解题思路

拯救行动(BFS)

STL栈+队列+优先队列(详)+ 拯救行动题解

AC日记——潜伏着 openjudge 1.7 11

P4116 Qtree3