how many tables

Posted 小时のblog

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了how many tables相关的知识,希望对你有一定的参考价值。

传送门

How Many Tables

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 30551    Accepted Submission(s): 15140


Problem Description
Today is Ignatius‘ birthday. He invites a lot of friends. Now it‘s dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.
 
Input
The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.
 
Output
For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.
 
Sample Input
2 5 3 1 2 2 3 4 5 5 1 2 5
 
Sample Output
2 4
 
Author
Ignatius.L
 
Source
【思路】
并查集求强连通分量的个数。
一直超时...我上一篇求个数的方法太low了....
每当合并一次时n--(点的个数)
。 。 。(本来三个点)
。 (..)   (合并了2个 3--是2)
【code】
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int far[1009];
int f(int x)
{
    return far[x]==x?x:f(far[x]);
}
int n,m,tot,t;
int main()
{
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&m)&&n;
        for(int i=1;i<=n;i++)
        far[i]=i;
        for(int i=1;i<=m;i++)
        {
            int x,y;
            scanf("%d%d",&x,&y);
            int p=f(x),q=f(y);
            if(p!=q)
            {
             far[p]=q;
             n--;
            }
        }
        printf("%d\n",n);
    }
    return 0;
}

 

 

以上是关于how many tables的主要内容,如果未能解决你的问题,请参考以下文章

How Many Tables——并查集模板题

HDU 1213 How Many Tables

how many tables

How Many Tables HDU - 1213

How Many Tables 简单并查集

How Many Tables-并查集