Pie POJ 3122 二分搜索

Posted joeylee97

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了Pie POJ 3122 二分搜索相关的知识,希望对你有一定的参考价值。

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 17324   Accepted: 5835   Special Judge

Description

技术分享My birthday is coming up and traditionally I‘m serving pie. Not just one pie, no, I have a number N of them, of various tastes and of various sizes. F of my friends are coming to my party and each of them gets a piece of pie. This should be one piece of one pie, not several small pieces since that looks messy. This piece can be one whole pie though.

My friends are very annoying and if one of them gets a bigger piece than the others, they start complaining. Therefore all of them should get equally sized (but not necessarily equally shaped) pieces, even if this leads to some pie getting spoiled (which is better than spoiling the party). Of course, I want a piece of pie for myself too, and that piece should also be of the same size. 

What is the largest possible piece size all of us can get? All the pies are cylindrical in shape and they all have the same height 1, but the radii of the pies can be different.

Input

One line with a positive integer: the number of test cases. Then for each test case:
  • One line with two integers N and F with 1 ≤ N, F ≤ 10 000: the number of pies and the number of friends.
  • One line with N integers ri with 1 ≤ ri ≤ 10 000: the radii of the pies.

Output

For each test case, output one line with the largest possible volume V such that me and my friends can all get a pie piece of size V. The answer should be given as a floating point number with an absolute error of at most 10?3.

Sample Input

3
3 3
4 3 3
1 24
5
10 5
1 4 2 3 4 5 6 5 4 2

Sample Output

25.1327
3.1416
50.2655

Source

#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<sstream>
#include<algorithm>
#include<queue>
#include<deque>
#include<iomanip>
#include<vector>
#include<cmath>
#include<map>
#include<stack>
#include<set>
#include<fstream>
#include<memory>
#include<list>
#include<string>
using namespace std;
typedef long long LL;
typedef unsigned long long ULL;
#define MAXN 10009
#define N 21
#define MOD 1000000
#define INF 1000000009
const double eps = 1e-6;
const double PI = acos(-1.0);
/*
给定n个圆 和 F个朋友
要求把这n个圆 分成(F+1)份 每一份要尽量大!
直接二分搜索 每一份的大小
*/
double s[MAXN];//面积
int n, f;
int sgn(double x)
{
    if (fabs(x) < eps)
        return 0;
    else if (x > 0)
        return 1;
    else
        return -1;
}
bool check(double x)
{
    int cnt = 0;
    for (int i = 0; i < n; i++)
    {
        cnt += floor(s[i] / x);
    }
    return cnt >= (f + 1);
}
int main()
{
    int T;
    scanf("%d", &T);
    while (T--)
    {
        scanf("%d%d", &n, &f);
        double tmp, l = 0.0, r;
        for (int i = 0; i < n; i++)
        {
            scanf("%lf", &tmp);
            s[i] = PI*tmp*tmp;
            r = max(s[i], r);
        }
        while (sgn(r-l)>0)
        {
            double mid = (l + r) / 2;
            if (check(mid))
                l = mid;
            else
                r = mid;
        }
        printf("%.4lf\n", l);
    }
}

 





以上是关于Pie POJ 3122 二分搜索的主要内容,如果未能解决你的问题,请参考以下文章

POJ 3122-Pie(二分+精度)

poj3122 Pie

POJ3122-Pie-二分答案

POJ 3122 Pie二分答案

POJ3122 Pie

poj 3122 Pie