国王游戏

Posted 小时のblog

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了国王游戏相关的知识,希望对你有一定的参考价值。

题目描述

恰逢 H 国国庆,国王邀请 n 位大臣来玩一个有奖游戏。首先,他让每个大臣在左、右

手上面分别写下一个整数,国王自己也在左、右手上各写一个整数。然后,让这 n 位大臣排

成一排,国王站在队伍的最前面。排好队后,所有的大臣都会获得国王奖赏的若干金币,每

位大臣获得的金币数分别是:排在该大臣前面的所有人的左手上的数的乘积除以他自己右

手上的数,然后向下取整得到的结果。

国王不希望某一个大臣获得特别多的奖赏,所以他想请你帮他重新安排一下队伍的顺序,

使得获得奖赏最多的大臣,所获奖赏尽可能的少。注意,国王的位置始终在队伍的最前面。

输入输出格式

输入格式:

 

第一行包含一个整数 n,表示大臣的人数。

第二行包含两个整数 a和 b,之间用一个空格隔开,分别表示国王左手和右手上的整数。

接下来 n 行,每行包含两个整数 a 和 b,之间用一个空格隔开,分别表示每个大臣左手

和右手上的整数。

 

输出格式:

 

输出只有一行,包含一个整数,表示重新排列后的队伍中获奖赏最多的大臣所获得的

金币数。

 

输入输出样例

输入样例#1:
3 
1 1 
2 3 
7 4 
4 6 
输出样例#1:
2

说明

【证明】

 

【code】

//洛谷50分做法 
#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;
#define LL long long
#define M 10005
int n;
LL ans=-1,sum;
struct Per
{
    LL l,r;
}person[M];
bool cmp(Per a,Per b)
{
    if(a.l==b.l)return a.r<b.r;
    return a.l<b.l;
}
int main()
{
    scanf("%d",&n);
    scanf("%lld%lld",&person[0].l,&person[0].r);
    for(int i=1;i<=n;i++)
    scanf("%lld%lld",&person[i].l,&person[i].r);
    sort(person+1,person+n+1,cmp);sum=person[0].l;
    for(int i=1;i<n;i++)
    {
        ans=max(ans,sum/person[i].r);
        sum*=person[i].l;
    }
    printf("%lld\n",ans);
    return 0;
}
//60分。 
#include<iostream>
#include<cstdio>
#include<algorithm> 
using namespace std;
#define LL long long
#define M 10005
struct Per
{
    LL l,r;
}person[M];
bool cmp(Per a,Per b)
{
    return a.l+a.r<b.l+b.r;
}
int n;
LL js=1,ans=-1;
int main()
{
    scanf("%d",&n);
    for(int i=0;i<=n;i++)
    {
        scanf("%d %d",&person[i].l,&person[i].r);
    }
    sort(person+1,person+n+1,cmp);
    js=person[0].l; 
    for(int i=1;i<=n;i++)
    {
        ans=max(ans,js/person[i].r);
        js*=person[i].l;
    }
    printf("%lld\n",ans);
    return 0;
}

实在不想打高精....QAQ.

以上是关于国王游戏的主要内容,如果未能解决你的问题,请参考以下文章

AcWing 国王游戏

1198 国王游戏

国王游戏 贪心+高精度

国王游戏

CODEVS 1198 国王游戏

国王的恩赐兵种代码怎么用