Constructing Roads HDU 1102

Posted 九月旧约

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了Constructing Roads HDU 1102相关的知识,希望对你有一定的参考价值。

There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected. 

We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.

Input

The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village i and village j. 

Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.

Output

You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum.

Sample Input

3
0 990 692
990 0 179
692 179 0
1
1 2

Sample Output

179
好久没写最小生成树了,今天还忘写了一个判断,贴出来长点记性,一个模版题
#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;
#define maxn 105
int mapn[maxn][maxn],vis[maxn],low[maxn],n;
void prim()
{
    int sum = 0;
    memset(vis,0,sizeof(vis));
    int pos = 1;
    for(int i=1;i<=n;i++)
        low[i] = mapn[1][i];
    vis[1] = 1;
    for(int i=1;i<n;i++)
    {
        int minn = 1e9;
        for(int j=1;j<=n;j++)
        {
            if(!vis[j]&&minn>low[j])//找下一个点到这个集合的最小值
            {
                minn=low[j];//记下这个最小值
                pos=j;//记下这个点
            }
        }
        if(minn == 1e9)
            return;
        sum += minn;
        vis[pos] = 1;
        for(int j=1;j<=n;j++)
        {
            if(!vis[j]&&low[j]>mapn[pos][j])
                low[j] = mapn[pos][j];
        }
    }
    cout << sum << endl;
}
int main()
{
    while(cin >> n)
    {
        for(int i=1;i<=n;i++)
            for(int j=1;j<=n;j++)
                cin >> mapn[i][j];
        int m;
        cin >> m;
        while(m--)
        {
            int a,b;
            cin >> a >> b;
            mapn[b][a] = 0;
            mapn[a][b] = 0;
        }
        prim();
    }
    return 0;
}

 

以上是关于Constructing Roads HDU 1102的主要内容,如果未能解决你的问题,请参考以下文章

HDU-1102 Constructing Roads ( 最小生成树 )

HDU1102--Constructing Roads(最小生成树)

HDU 1102 Constructing Roads

hdu1102 Constructing Roads 基础最小生成树

hdu 1102 Constructing Roads (Prim算法)

hdu1102 Constructing Roads 最小生成树prime