POJ 3014:Asteroids(二分匹配,匈牙利算法)

Posted claireyuancy

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了POJ 3014:Asteroids(二分匹配,匈牙利算法)相关的知识,希望对你有一定的参考价值。

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 14399   Accepted: 7836

Description

Bessie wants to navigate her spaceship through a dangerous asteroid field in the shape of an N x N grid (1 <= N <= 500). The grid contains K asteroids (1 <= K <= 10,000), which are conveniently located at the lattice points of the grid. 

Fortunately, Bessie has a powerful weapon that can vaporize all the asteroids in any given row or column of the grid with a single shot.This weapon is quite expensive, so she wishes to use it sparingly.Given the location of all the asteroids in the field, find the minimum number of shots Bessie needs to fire to eliminate all of the asteroids.

Input

* Line 1: Two integers N and K, separated by a single space. 
* Lines 2..K+1: Each line contains two space-separated integers R and C (1 <= R, C <= N) denoting the row and column coordinates of an asteroid, respectively.

Output

* Line 1: The integer representing the minimum number of times Bessie must shoot.

Sample Input

3 4
1 1
1 3
2 2
3 2

Sample Output

2

Hint

INPUT DETAILS: 
The following diagram represents the data, where "X" is an asteroid and "." is empty space: 
X.X 
.X. 
.X.
 

OUTPUT DETAILS: 
Bessie may fire across row 1 to destroy the asteroids at (1,1) and (1,3), and then she may fire down column 2 to destroy the asteroids at (2,2) and (3,2).

好吧。。这类型的简单题就先刷到这把。。改深化投入了。。


#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>

using namespace std;

const int M = 1000 + 5;
int n, m;
int link[M];
bool MAP[M][M];
bool cover[M];
int ans;

void init()
{
    int num;
    int x;
    int y;
    memset(MAP, false, sizeof(MAP));
    for(int i=1; i<=m; i++)
    {
            scanf("%d%d", &x, &y);
            MAP[x][y]=true;
    }

}

bool dfs(int x)
{
    for(int y=1; y<=n; y++)
    {
        if(MAP[x][y] && !cover[y])
        {
            cover[y]=true;
            if(link[y]==-1 || dfs(link[y]))
            {
                link[y]=x;
                return true;
            }
        }
    }
    return false;
}

int main()
{
    while(scanf("%d%d", &n, &m)!=EOF)
    {
        ans=0;
        init();
        memset(link, -1, sizeof(link));
        for(int i=1; i<=n; i++)
        {
            memset(cover, false, sizeof(cover));
            if( dfs(i) )
                ans++;
        }
        printf("%d\n", ans);
    }

    return 0;
}




以上是关于POJ 3014:Asteroids(二分匹配,匈牙利算法)的主要内容,如果未能解决你的问题,请参考以下文章

poj3041 Asteroids(二分图最小顶点覆盖二分图匹配)

二分匹配入门专题1G - Asteroids poj3041最小顶点覆盖

POJ #3041 Asteroids 3041 二分图最小覆盖 最大匹配 匈牙利算法

POJ 3041 Asteroids 二分图之最大匹配

poj3041 Asteroids

POJ 3041 Asteroids(二分图 && 匈牙利算法 && 最小点覆盖)