Bridging signals(NlogN最长上升子序列)

Posted 勿忘初心0924

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了Bridging signals(NlogN最长上升子序列)相关的知识,希望对你有一定的参考价值。

Bridging signals

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2354    Accepted Submission(s): 1536


Problem Description
‘Oh no, they‘ve done it again‘, cries the chief designer at the Waferland chip factory. Once more the routing designers have screwed up completely, making the signals on the chip connecting the ports of two functional blocks cross each other all over the place. At this late stage of the process, it is too
expensive to redo the routing. Instead, the engineers have to bridge the signals, using the third dimension, so that no two signals cross. However, bridging is a complicated operation, and thus it is desirable to bridge as few signals as possible. The call for a computer program that finds the maximum number of signals which may be connected on the silicon surface without rossing each other, is imminent. Bearing in mind that there may be housands of signal ports at the boundary of a functional block, the problem asks quite a lot of the programmer. Are you up to the task?
技术分享
Figure 1. To the left: The two blocks‘ ports and their signal mapping (4,2,6,3,1,5). To the right: At most three signals may be routed on the silicon surface without crossing each other. The dashed signals must be bridged. 

A typical situation is schematically depicted in figure 1. The ports of the two functional blocks are numbered from 1 to p, from top to bottom. The signal mapping is described by a permutation of the numbers 1 to p in the form of a list of p unique numbers in the range 1 to p, in which the i:th number pecifies which port on the right side should be connected to the i:th port on the left side.
Two signals cross if and only if the straight lines connecting the two ports of each pair do.
 

 

Input
On the first line of the input, there is a single positive integer n, telling the number of test scenarios to follow. Each test scenario begins with a line containing a single positive integer p<40000, the number of ports on the two functional blocks. Then follow p lines, describing the signal mapping: On the i:th line is the port number of the block on the right side which should be connected to the i:th port of the block on the left side.
 

 

Output
For each test scenario, output one line containing the maximum number of signals which may be routed on the silicon surface without crossing each other.
 

 

Sample Input
4 6 4 2 6 3 1 5 10 2 3 4 5 6 7 8 9 10 1 8 8 7 6 5 4 3 2 1 9 5 8 9 2 3 1 7 4 6
 

 

Sample Output
3 9 1 4
 

 

Source
 
/*----------------------------------------------
File: F:\ACM源代码\动态规划\最长上升子序列\HDU1950.cpp
Date: 2017/5/30 10:24:29
Author: LyuCheng
----------------------------------------------*/
#include <bits/stdc++.h>
#define MAXN 40005

using namespace std;

int n,t,len;
int b[MAXN],d[MAXN];
int binary_seacher(int i){
    int left,right,mid;
    left=0,right=len;
    while(left<right){
        mid=left+(right-left)/2;
        if(b[mid]>=d[i]) right=mid;
        else left=mid+1;
    }
    return left;
}
int main(int argc, char *argv[])
{
    // freopen("in.txt","r",stdin);
    scanf("%d",&t);
    while(t--){
        scanf("%d",&n);
        for(int i=1;i<=n;i++){
            scanf("%d",&d[i]);
        }
        b[1]=d[1];
        len=1;
        for(int i=2;i<=n;i++){
            if(b[len]<d[i]){
                b[++len]=d[i];
            }else{
                int pos=binary_seacher(i);
                b[pos]=d[i];
            }
        }
        printf("%d\n",len);
    }
    return 0;
}

 

以上是关于Bridging signals(NlogN最长上升子序列)的主要内容,如果未能解决你的问题,请参考以下文章

POJ 1631 Bridging signals

HDU1950-Bridging signals-最长上升子序列

hdu---1950---Bridging signals解题报告(求Lis n*logn贪心+二分搜索)

HDU 1950 Bridging signals(LIS)

POJ - 1631 Bridging signals(最长上升子序列---LIS)

Bridging signals POJ 1631(最长递增子序列dp)