poj 3264 Balanced Lineup

Posted yifan2016

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了poj 3264 Balanced Lineup相关的知识,希望对你有一定的参考价值。

Balanced Lineup
Time Limit: 5000MS   Memory Limit: 65536K
Total Submissions: 42489   Accepted: 20000
Case Time Limit: 2000MS

Description

For the daily milking, Farmer John‘s N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer John decides to organize a game of Ultimate Frisbee with some of the cows. To keep things simple, he will take a contiguous range of cows from the milking lineup to play the game. However, for all the cows to have fun they should not differ too much in height.

Farmer John has made a list of Q (1 ≤ Q ≤ 200,000) potential groups of cows and their heights (1 ≤ height ≤ 1,000,000). For each group, he wants your help to determine the difference in height between the shortest and the tallest cow in the group.

Input

Line 1: Two space-separated integers, N and Q.
Lines 2..N+1: Line i+1 contains a single integer that is the height of cow i
Lines N+2..N+Q+1: Two integers A and B (1 ≤ ABN), representing the range of cows from A to B inclusive.

Output

Lines 1..Q: Each line contains a single integer that is a response to a reply and indicates the difference in height between the tallest and shortest cow in the range.

Sample Input

6 3
1
7
3
4
2
5
1 5
4 6
2 2

Sample Output

6
3
0

题目大意,给定一个数组,求任意给定区间的最大值与最小值只差
典型的线段树问题,但是由于输入输出的数据量很大,所以只能使用scanf,printf进行输入输出,如果使用cin,cout则会超时
我的ac代码:
#include<iostream>
#include<algorithm>
#include<stdio.h>
using namespace std;
struct node{
    int r,l,vmin,vmax;
}tree[600500];
int a[155000];
void createTree(int v,int l,int r){
    tree[v].l=l;
    tree[v].r=r;
    if(l==r){
        tree[v].vmax=tree[v].vmin=a[l];
        return ;
    }
    int mid=(r+l)>>1;
    createTree(v<<1,l,mid);
    createTree((v<<1)|1,mid+1,r);
    tree[v].vmax=max(tree[v<<1].vmax,tree[(v<<1)|1].vmax);
    tree[v].vmin=min(tree[v<<1].vmin,tree[(v<<1)|1].vmin);
}
int findAns(int v,int l,int r,bool f){
    if(tree[v].l==l&&tree[v].r==r){
        if(f)return tree[v].vmin;
        return tree[v].vmax;
    } 
    int mid=(tree[v].l+tree[v].r)>>1;
    if(r<=mid)return findAns(v<<1,l,r,f);
    if(l>mid) return findAns((v<<1)|1,l,r,f);
    if(f) return min(findAns(v<<1,l,mid,f),findAns((v<<1)|1,mid+1,r,f));
    return max(findAns(v<<1,l,mid,f),findAns((v<<1)|1,mid+1,r,f));
}
int main(){
    int N,Q,l,r;
    while(cin>>N>>Q){
        for(int i=1;i<=N;i++)  
            scanf("%d",&a[i]);  
  
        createTree(1,1,N);  
        while(Q--){
            scanf("%d%d",&l,&r);  
            printf("%d\n",findAns(1,l,r,0)-findAns(1,l,r,1));  
        } 
    }
    return 0;
}

 

以上是关于poj 3264 Balanced Lineup的主要内容,如果未能解决你的问题,请参考以下文章

Balanced Lineup POJ - 3264

POJ 3264 Balanced Lineup

POJ3264 Balanced Lineup

poj3264 Balanced Lineup 2011-12-20

POJ 3264 Balanced Lineup

POJ 3264 Balanced Lineup