POJ训练计划1035_Spell checker(串处理/暴力)

Posted gcczhongduan

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了POJ训练计划1035_Spell checker(串处理/暴力)相关的知识,希望对你有一定的参考价值。

Spell checker
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 18418   Accepted: 6759

Description

You, as a member of a development team for a new spell checking program, are to write a module that will check the correctness of given words using a known dictionary of all correct words in all their forms. 
If the word is absent in the dictionary then it can be replaced by correct words (from the dictionary) that can be obtained by one of the following operations: 
?

deleting of one letter from the word; 
?replacing of one letter in the word with an arbitrary letter; 
?

inserting of one arbitrary letter into the word. 
Your task is to write the program that will find all possible replacements from the dictionary for every given word. 

Input

The first part of the input file contains all words from the dictionary. Each word occupies its own line. This part is finished by the single character ‘#‘ on a separate line. All words are different. There will be at most 10000 words in the dictionary. 
The next part of the file contains all words that are to be checked. Each word occupies its own line. This part is also finished by the single character ‘#‘ on a separate line. There will be at most 50 words that are to be checked. 
All words in the input file (words from the dictionary and words to be checked) consist only of small alphabetic characters and each one contains 15 characters at most. 

Output

Write to the output file exactly one line for every checked word in the order of their appearance in the second part of the input file. If the word is correct (i.e. it exists in the dictionary) write the message: " is correct". If the word is not correct then write this word first, then write the character ‘:‘ (colon), and after a single space write all its possible replacements, separated by spaces. The replacements should be written in the order of their appearance in the dictionary (in the first part of the input file). If there are no replacements for this word then the line feed should immediately follow the colon.

Sample Input

i
is
has
have
be
my
more
contest
me
too
if
award
#
me
aware
m
contest
hav
oo
or
i
fi
mre
#

Sample Output

me is correct
aware: award
m: i my me
contest is correct
hav: has have
oo: too
or:
i is correct
fi: i
mre: more me

Source

解题报告
怕超时写哈希。结果还真超时了。改写暴力居然过了。。。

C++只是,G++过。。

#include <cstdio>
#include <iostream>
#include <cstring>
#include <algorithm>
#include <cmath>

using namespace std;
struct node
{
    char s[20];
    int t;
} dic[10010];
int ctt(char *str,char *ch)
{
    int l1=strlen(str),l2=strlen(ch);
    int i,t=0;
    if(l1<l2)
    {
        for(i=0;i<l2;i++)
        {
            if(str[t]==ch[i])
                t++;
            if(t==l1)
                return 1;
        }
        return 0;
    }
    else if(l1>l2)
    {
        for(i=0;i<l1;i++)
        {
            if(str[i]==ch[t])
                t++;
            if(t==l2)
                return 1;
        }
        return 0;
    }
    else
    {
        for(i=0;i<l1;i++)
        {
            if(str[i]==ch[i])
                t++;
        }
        if(t==l1-1)
            return 1;
        else
        return 0;
    }
}
int main()
{
    int n=0,f=0,i;
    char str[20];
    while(~scanf("%s",str))
    {
        if(str[0]=='#')break;
        strcpy(dic[n].s,str);
        dic[n++].t=n;
    }
    //<<ctt("aware","award");
    while(~scanf("%s",str))
    {
        f=0;
        if(str[0]=='#')break;
        for(i=0; i<n; i++)
        {
            if(strcmp(str,dic[i].s)==0)
            {
                printf("%s is correct",str);
                f=1;
                break;
            }
        }
        if(!f)
        {
            printf("%s:",str);
            int l=strlen(str);
            for(i=0; i<n; i++)
            {
                if(strlen(dic[i].s)-l==1||strlen(dic[i].s)-l==-1||strlen(dic[i].s)-l==0)
                {
                    if(ctt(str,dic[i].s))
                        printf(" %s");
                }
            }
        }
        printf("\n");
    }
}


以上是关于POJ训练计划1035_Spell checker(串处理/暴力)的主要内容,如果未能解决你的问题,请参考以下文章

POJ 1035 Spell checker (模拟)

poj-1035-Spell Checker

Spell checker POJ 1035 字符串

POJ 1035Spell checker

[POJ1035]Spell checker

poj1035Spell checker