HDU 1412 {A} + {B}

Posted claireyuancy

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了HDU 1412 {A} + {B}相关的知识,希望对你有一定的参考价值。

Problem Description
给你两个集合。要求{A} + {B}.
注:同一个集合中不会有两个同样的元素.
 

Input
每组输入数据分为三行,第一行有两个数字n,m(0<n,m<=10000),分别表示集合A和集合B的元素个数.后两行分别表示集合A和集合B.每一个元素为不超出int范围的整数,每一个元素之间有一个空格隔开.
 

Output
针对每组数据输出一行数据,表示合并后的集合,要求从小到大输出,每一个元素之间有一个空格隔开.
 

Sample Input
1 2 1 2 3 1 2 1 1 2
 

Sample Output
1 2 3 1 2
 
看到大神用STL,写的如此犀利。忍不住来一发。。
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<limits.h>
#include<list>
using namespace std;

int main()
{
    int n,m,x;
    list<int>s1;
    list<int>s2;
    while(cin>>n>>m)
    {
        for(int i=0;i<n;i++)
        {
            cin>>x;
            s1.push_back(x);
        }
        for(int i=0;i<m;i++)
        {
            cin>>x;
            s2.push_back(x);
        }
        s1.merge(s2);
        s1.sort();
        s1.unique();
        int cnt=0;
        while(!s1.empty())
        {
           if(!cnt)
                cout<<s1.front();
           else
                cout<<" "<<s1.front();
           cnt=1;
           s1.pop_front();
        }
        cout<<endl;
    }
    return 0;
}


以上是关于HDU 1412 {A} + {B}的主要内容,如果未能解决你的问题,请参考以下文章

HDU 1412 {A} + {B}

{A} + {B} HDU - 1412

STL应用——hdu1412(set)

动态 Rstudio 代码片段

基础算法|6 折半插入排序 - HDU 1412

HDU4057 Rescue the Rabbit(AC自动机+状压DP)