Playrix Codescapes Cup (Codeforces Round #413, rated, Div. 1 + Div. 2)B. T-shirt buying

Posted

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了Playrix Codescapes Cup (Codeforces Round #413, rated, Div. 1 + Div. 2)B. T-shirt buying相关的知识,希望对你有一定的参考价值。

传送门

Description

A new pack of n t-shirts came to a shop. Each of the t-shirts is characterized by three integers piai and bi, where pi is the price of the i-th t-shirt, ai is front color of the i-th t-shirt and bi is back color of the i-th t-shirt. All values pi are distinct, and values ai and bi are integers from 1 to 3.

m buyers will come to the shop. Each of them wants to buy exactly one t-shirt. For the j-th buyer we know his favorite color cj.

A buyer agrees to buy a t-shirt, if at least one side (front or back) is painted in his favorite color. Among all t-shirts that have colors acceptable to this buyer he will choose the cheapest one. If there are no such t-shirts, the buyer won‘t buy anything. Assume that the buyers come one by one, and each buyer is served only after the previous one is served.

You are to compute the prices each buyer will pay for t-shirts.

Input

The first line contains single integer n (1 ≤ n ≤ 200 000) — the number of t-shirts.

The following line contains sequence of integers p1, p2, ..., pn (1 ≤ pi ≤ 1 000 000 000), where pi equals to the price of the i-th t-shirt.

The following line contains sequence of integers a1, a2, ..., an (1 ≤ ai ≤ 3), where ai equals to the front color of the i-th t-shirt.

The following line contains sequence of integers b1, b2, ..., bn (1 ≤ bi ≤ 3), where bi equals to the back color of the i-th t-shirt.

The next line contains single integer m (1 ≤ m ≤ 200 000) — the number of buyers.

The following line contains sequence c1, c2, ..., cm (1 ≤ cj ≤ 3), where cj equals to the favorite color of the j-th buyer. The buyers will come to the shop in the order they are given in the input. Each buyer is served only after the previous one is served.

Output

Print to the first line m integers — the j-th integer should be equal to the price of the t-shirt which the j-th buyer will buy. If the j-th buyer won‘t buy anything, print -1.

Sample Input

5
300 200 400 500 911
1 2 1 2 3
2 1 3 2 1
6
2 3 1 2 1 1

2
1000000000 1
1 1
1 2
2
2 1

Sample Output

200 400 300 500 911 -1 

1 1000000000 

Note

 

思路

题意:

 

题解:

 

 

#include<bits/stdc++.h>
using namespace std;
const int maxn = 200005;
int p[maxn],a[maxn],b[maxn];
bool vis[maxn];
set<pair<int,int> >s[5];

int main()
{
	int n,m,t;
	scanf("%d",&n);
	for (int i = 0;i < n;i++)	scanf("%d",&p[i]);
	for (int i = 0;i < n;i++)	scanf("%d",&a[i]);
	for (int i = 0;i < n;i++)	scanf("%d",&b[i]);
	for (int i = 0;i < n;i++)
	{
		s[a[i]].insert(make_pair(p[i],i));
		s[b[i]].insert(make_pair(p[i],i));
		vis[i] = true;
	}
	scanf("%d",&m);
	while (m--)
	{
		int ans = -1;
		scanf("%d",&t);
		while (!s[t].empty())
		{
			int pos = (*(s[t].begin())).second;
			s[t].erase(s[t].begin());
			if (!vis[pos])	continue;
			ans = p[pos];
			vis[pos] = false;
			break;
		}
		printf("%d ",ans);
	}
	puts(" ");
	return 0;
}

  

 

以上是关于Playrix Codescapes Cup (Codeforces Round #413, rated, Div. 1 + Div. 2)B. T-shirt buying的主要内容,如果未能解决你的问题,请参考以下文章

Playrix Codescapes Cup (Codeforces Round #413, rated, Div. 1 + Div. 2) C. Fountains 树状数组维护区间最大值(示(代

集合运算基本法则

Forethought Future Cup - Elimination Round

Codeforces 855C. Helga Hufflepuff's Cup----树形DP

Codeforces Round #405 (rated, Div. 2, based on VK Cup 2017 Round 1) C

Problem L. World Cup