POJ 3061 Subsequence 尺取

Posted joeylee97

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了POJ 3061 Subsequence 尺取相关的知识,希望对你有一定的参考价值。

Subsequence
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 14698   Accepted: 6205

Description

A sequence of N positive integers (10 < N < 100 000), each of them less than or equal 10000, and a positive integer S (S < 100 000 000) are given. Write a program to find the minimal length of the subsequence of consecutive elements of the sequence, the sum of which is greater than or equal to S.

Input

The first line is the number of test cases. For each test case the program has to read the numbers N and S, separated by an interval, from the first line. The numbers of the sequence are given in the second line of the test case, separated by intervals. The input will finish with the end of file.

Output

For each the case the program has to print the result on separate line of the output file.if no answer, print 0.

Sample Input

2
10 15
5 1 3 5 10 7 4 9 2 8
5 11
1 2 3 4 5

Sample Output

2
3

Source

 

#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<sstream>
#include<algorithm>
#include<queue>
#include<deque>
#include<iomanip>
#include<vector>
#include<cmath>
#include<map>
#include<stack>
#include<set>
#include<fstream>
#include<memory>
#include<list>
#include<string>
using namespace std;
typedef long long LL;
typedef unsigned long long ULL;
#define MAXN 100004
#define L 31
#define INF 1000000009
#define eps 0.00000001
/*
尺取
*/
int a[MAXN], n, s;
int main()
{
    int t;
    scanf("%d", &t);
    while (t--)
    {
        scanf("%d%d", &n, &s);
        for (int i = 0; i < n; i++)
            scanf("%d", &a[i]);
        int l = 0,sum = 0,ans = INF;
        for (int r = 0; r < n; r++)
        {
            sum += a[r];
            while (sum >= s)
            {
                sum -= a[l];
                ans = min(r - l + 1, ans);
                l++;
            }
        }
        if (ans != INF)
            printf("%d\n", ans);
        else
            printf("0\n");
    }
}

 

以上是关于POJ 3061 Subsequence 尺取的主要内容,如果未能解决你的问题,请参考以下文章

POJ 3061 Subsequence 尺取

POJ-3061 Subsequence 二分或尺取

poj3061 Subsequence(尺取法)

POJ 3061 Subsequence(Two Pointers)

poj3061 Subsequence

Subsequence(POJ 3061)