hdoj-3371-Connect the Cities最小生成树

Posted yxysuanfa

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了hdoj-3371-Connect the Cities最小生成树相关的知识,希望对你有一定的参考价值。

Connect the Cities

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 13299 Accepted Submission(s): 3618


Problem Description
In 2100, since the sea level rise, most of the cities disappear. Though some survived cities are still connected with others, but most of them become disconnected. The government wants to build some roads to connect all of these cities again, but they don’t want to take too much money.

Input
The first line contains the number of test cases.
Each test case starts with three integers: n, m and k. n (3 <= n <=500) stands for the number of survived cities, m (0 <= m <= 25000) stands for the number of roads you can choose to connect the cities and k (0 <= k <= 100) stands for the number of still connected cities.
To make it easy, the cities are signed from 1 to n.
Then follow m lines, each contains three integers p, q and c (0 <= c <= 1000), means it takes c to connect p and q.
Then follow k lines, each line starts with an integer t (2 <= t <= n) stands for the number of this connected cities. Then t integers follow stands for the id of these cities.

Output
For each case, output the least money you need to take, if it’s impossible, just output -1.

Sample Input
1 6 4 3 1 4 2 2 6 1 2 3 5 3 4 33 2 1 2 2 1 3 3 4 5 6

Sample Output
1

Author
dandelion

Source

Recommend
lcy | We have carefully selected several similar problems for you: 1301 2544 1598 2066 1874

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
struct graph{
	int a;
	int b;
	int cost;
}G[ 25005];
int root[505];
int n,m;
int find(int i){
	if(root[i]==i) return i;
	return root[i]=find(root[i]);
}
void unio(int i,int j){
	int t=find(i);
	int k=find(j);
	if(t<=k) root[k]=t;
	else root[t]=k;
	return ;
}
int cmp(graph u,graph v){
	return u.cost<v.cost;
}
int shortest;
void kruskal(){
	sort(G,G+m,cmp); 
	int i,t,k;
	shortest=0;
	for(i=0;i<m;++i){
		t=find(G[i].a); k=find(G[i].b);
		if(t!=k){
			unio(t,k);
			shortest+=G[i].cost;
		}
	}
	return ;
}
int main(){
	int T;
	scanf("%d",&T);
	while(T--){
		int k,i,j,p,q,c,t,x,y;
		scanf("%d%d%d",&n,&m,&k);
		for(i=1;i<=n;++i) root[i] = i;
		for(i=0;i<m;++i){
			scanf("%d%d%d",&p,&q,&c);
			G[i].a=p,G[i].b=q,G[i].cost=c;
		}
		for(i=1;i<=k;++i){
			scanf("%d",&t);
			scanf("%d%d",&x,&y);
			unio(x,y);
			for(j=3;j<=t;++j){
				scanf("%d",&y);
				unio(x,y);
			}
			
		}
		kruskal();
		int nu=0;
		for(i=1;i<=n;++i){
			if(find(i)==i) nu++;
		}
		if(nu>1) printf("-1\n");
		else printf("%d\n",shortest);
		
	}
	return 0;
}


以上是关于hdoj-3371-Connect the Cities最小生成树的主要内容,如果未能解决你的问题,请参考以下文章

apache_conf Bulkloader Obeiros.cit

Cit 忽略特定文件或文件夹

慢更新查询 SQLite

Mongoose.connect 不工作

js三级联动

js循环