HDUJ 2070 Fibbonacci Number

Posted gccbuaa

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了HDUJ 2070 Fibbonacci Number相关的知识,希望对你有一定的参考价值。

Fibbonacci Number

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 13234    Accepted Submission(s): 6628


Problem Description
Your objective for this question is to develop a program which will generate a fibbonacci number. The fibbonacci function is defined as such:

f(0) = 0
f(1) = 1
f(n) = f(n-1) + f(n-2)

Your program should be able to handle values of n in the range 0 to 50.
 

Input
Each test case consists of one integer n in a single line where 0≤n≤50. The input is terminated by -1.
 

Output
Print out the answer in a single line for each test case.
 

Sample Input
3 4 5 -1
 

Sample Output
2 3 5


#include<iostream>
#include<cstring>
using namespace std;

int main()
{
	__int64 a[55];
	a[0]=0,a[1]=1;
	for(int i=2;i<=50;i++)
		a[i]=a[i-1]+a[i-2];

	int n;
	while(cin>>n)
	{
		if(n==-1)  break;
		printf("%I64d\n",a[n]);
	}
	return 0;
}


以上是关于HDUJ 2070 Fibbonacci Number的主要内容,如果未能解决你的问题,请参考以下文章

HDUJ 2052 Picture 模拟

c_cpp Fibbonacci系列

c_cpp Fibbonacci系列

2Q - Fibbonacci Number

HDUJ 1019 Least Common Multiple

HDUJ 1203 I NEED A OFFER!