hdoj-1856-More is better并查集

Posted zhchoutai

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了hdoj-1856-More is better并查集相关的知识,希望对你有一定的参考价值。

More is better

Time Limit: 5000/1000 MS (Java/Others) Memory Limit: 327680/102400 K (Java/Others)
Total Submission(s): 18427 Accepted Submission(s): 6779


Problem Description
Mr Wang wants some boys to help him with a project. Because the project is rather complex, the more boys come, the better it will be. Of course there are certain requirements.

Mr Wang selected a room big enough to hold the boys. The boy who are not been chosen has to leave the room immediately. There are 10000000 boys in the room numbered from 1 to 10000000 at the very beginning. After Mr Wang‘s selection any two of them who are still in this room should be friends (direct or indirect), or there is only one boy left. Given all the direct friend-pairs, you should decide the best way.

Input
The first line of the input contains an integer n (0 ≤ n ≤ 100 000) - the number of direct friend-pairs. The following n lines each contains a pair of numbers A and B separated by a single space that suggests A and B are direct friends. (A ≠ B, 1 ≤ A, B ≤ 10000000)

Output
The output in one line contains exactly one integer equals to the maximum number of boys Mr Wang may keep.

Sample Input
4 1 2 3 4 5 6 1 6 4 1 2 3 4 5 6 7 8

Sample Output
4 2
Hint
A and B are friends(direct or indirect), B and C are friends(direct or indirect), then A and C are also friends(indirect). In the first sample {1,2,5,6} is the result. In the second sample {1,2},{3,4},{5,6},{7,8} are four kinds of answers.

Author

Source

Recommend
lcy | We have carefully selected several similar problems for you: 1325 1102 1301 1829 1811


#include<stdio.h>
#include<string.h>
#include<algorithm>
int maxn=-1;
using namespace std;
int root[10000001];
int res[10000001];
int find(int i){
	if(root[i]==i) return i;
	return root[i]=find(root[i]);
}
void unio(int x,int y){
	int p=find(x),q=find(y);
	if(p<=q) root[q]=p,res[p]+=res[q],maxn=max(maxn,res[p]);  // 在合并的时候顺便查找最大值。降低时间开销。否则超时!。!

else root[p]=q,res[q]+=res[p],maxn=max(maxn,res[q]); return; } int main(){ int n; while(~scanf("%d",&n)){ if(n==0){ printf("1\n"); continue; } memset(res,0,sizeof(res)); int i,x,y,a,b; maxn=-1; for(i=1;i<=10000000;++i) root[i]=i,res[i]=1; for(i=1;i<=n;++i){ scanf("%d%d",&a,&b); x=find(a);y=find(b); if(x!=y){ unio(x,y); } } printf("%d\n",maxn); } return 0; }



以上是关于hdoj-1856-More is better并查集的主要内容,如果未能解决你的问题,请参考以下文章

HDU1865--More is better(统计并查集的秩(元素个数))

More is better(hdu 1856 计算并查集集合中元素个数最多的集合)

[并查集] More is Better

More Is better-并查集

HDU 1856 More is better

hdu--1856 More is better