hdu 3549 Flow Problem(最大流模板题)

Posted brucemengbm

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了hdu 3549 Flow Problem(最大流模板题)相关的知识,希望对你有一定的参考价值。

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=3549


Problem Description
Network flow is a well-known difficult problem for ACMers. Given a graph, your task is to find out the maximum flow for the weighted directed graph.
 
Input
The first line of input contains an integer T, denoting the number of test cases.
For each test case, the first line contains two integers N and M, denoting the number of vertexes and edges in the graph. (2 <= N <= 15, 0 <= M <= 1000)
Next M lines, each line contains three integers X, Y and C, there is an edge from X to Y and the capacity of it is C. (1 <= X, Y <= N, 1 <= C <= 1000)

Output
For each test cases, you should output the maximum flow from source 1 to sink N.
 
Sample Input
2 3 2 1 2 1 2 3 1 3 3 1 2 1 2 3 1 1 3 1
 
Sample Output
Case 1: 1 Case 2: 2

代码例如以下:

#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;
const int MAXN = 32;//点数的最大值
const int MAXM = 1017;//边数的最大值
const int INF = 0x3f3f3f3f;
struct Edge
{
	int to, cap, flow;
	int next;
}edge[MAXM];//注意是MAXM
int tol;
int head[MAXN];
int dep[MAXN],pre[MAXN],cur[MAXN];
int gap[MAXN];//gap[x]=y :说明残留网络中dep[i]==x的个数为y
void init()
{
	tol = 0;
	memset(head,-1,sizeof (head));
}
//加边,单向图三个參数。双向图四个參数
void addedge (int u,int v,int w,int rw=0)
{
	edge[tol].to = v;edge[tol].cap = w;
	edge[tol].next = head[u];
	edge[tol].flow = 0;
	head[u] = tol++;
	edge[tol].to = u;edge[tol].cap = rw;
	edge[tol]. next = head[v];
	edge[tol].flow = 0;head[v]=tol++;
}
//输入參数:起点、终点、点的总数
//点的编号没有影响,仅仅要输入点的总数
int sap(int start,int end, int N)
{
	memset(gap,0,sizeof(gap));
	memset(dep,0,sizeof(dep));
	memcpy(cur,head,sizeof(head));
	int u = start;
	pre[u] = -1;
	gap[0] = N;
	int ans = 0;
	int i;
	while(dep[start] < N)
	{
		if(u == end)
		{
			int Min = INF;
			for( i = pre[u];i != -1; i = pre[edge[i^1]. to])
			{
				if(Min > edge[i].cap - edge[i]. flow)
					Min = edge[i].cap - edge[i].flow;
			}
			for( i = pre[u];i != -1; i = pre[edge[i^1]. to])
			{
				edge[i].flow += Min;
				edge[i^1].flow -= Min;
			}
			u = start;
			ans += Min;
			continue;
		}
		bool flag =  false;
		int v;
		for( i = cur[u]; i != -1;i = edge[i].next)
		{
			v = edge[i]. to;
			if(edge[i].cap - edge[i].flow && dep[v]+1 == dep[u])
			{
				flag =  true;
				cur[u] = pre[v] = i;
				break;
			}
		}
		if(flag)
		{
			u = v;
			continue;
		}
		int Min = N;
		for( i = head[u]; i !=  -1; i = edge[i]. next)
		{
			if(edge[i].cap - edge[i].flow && dep[edge[i].to] < Min)
			{
				Min = dep[edge[i].to];
				cur[u] = i;
			}
		}
		gap[dep[u]]--;
		if(!gap[dep[u]]) 
			return ans;
		dep[u] = Min+1;
		gap[dep[u]]++;
		if(u != start) 
			u = edge[pre[u]^1].to;
	}
	return ans;
}
int main()
{
	int n, m;
	int a, b, w;
	int c, s, t;
	int i;
	int T;
	int cas = 0;
	scanf("%d",&T);
	while(T--)
	{
		init();//初始化    
		scanf("%d%d",&n,&m);
		for(i = 1; i <= m; i++)//边数
		{
			scanf("%d%d%d",&a,&b,&w);
			addedge(a,b,w,0);
		//	addedge(b,a,w,0);
		}
		int ans = sap(1, n, n);
		printf("Case %d: %d\n",++cas,ans);
	}
	return 0;
}


以上是关于hdu 3549 Flow Problem(最大流模板题)的主要内容,如果未能解决你的问题,请参考以下文章

hdu 3549 Flow Problem (最大流入门题)

HDU-3549-Flow Problem

HDU3549_Flow Problem(网络流/EK)

题解报告:hdu 3549 Flow Problem(最大流入门)

HDOJ3549-Flow Problem(最大流)

hdu 3549 Flow Problem