SDUT 1068-Number Steps(数学:直线)

Posted lytwajue

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了SDUT 1068-Number Steps(数学:直线)相关的知识,希望对你有一定的参考价值。

Number Steps

Time Limit: 1000ms   Memory limit: 10000K  有疑问?点这里^_^

题目描写叙述

Starting from point (0,0) on a plane, we have written all non-negative integers 0, 1, 2,... as shown in the figure. For example, 1, 2, and 3 has been written at points (1,1), (2,0), and (3, 1) respectively and this pattern has continued. 

技术分享
 You are to write a program that reads the coordinates of a point (x, y), and writes the number (if any) that has been written at that point. (x, y) coordinates in the input are in the range 0...5000.

输入

The first line of the input is N, the number of test cases for this problem. In each of the N following lines, there is x, and y representing the coordinates (x, y) of a point.

输出

For each point in the input, write the number written at that point or write No Number if there is none.

演示样例输入

3
4 2
6 6
3 4

演示样例输出

6
12
No Number
就是按图中的规律给出两条直线。。

我一開始竟然没看出来是直线。。找规律打表敲了一大片结果wa了,后来发现就是推断点是否在直线上嘛 两条直线分别为y=x与y=x-2; 然后那个编号能够依据坐标x写出相应关系,非常好写,都是等差数列。我是分奇偶讨论的。。

#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cstring>
#include <cctype>
#include <cmath>
#include <cstdlib>
#include <vector>
#include <queue>
#include <set>
#include <map>
#include <list>
#define ll long long
using namespace std;
const int INF=1<<27;
const int maxn=1010;
int main()
{
	int x,y,n;
	scanf("%d",&n);
	while(n--)
	{
		scanf("%d%d",&x,&y);
		if(x==y)
		{
			if(x%2)
				printf("%d\n",2*x-1);
			else
				printf("%d\n",2*x);
		}
		else if(y==x-2)
		{
			if(x%2)
				printf("%d\n",2*x-3);
			else
				printf("%d\n",2*x-2);
		}
		else
			puts("No Number");
	}
    return 0;
}








以上是关于SDUT 1068-Number Steps(数学:直线)的主要内容,如果未能解决你的问题,请参考以下文章

SDUT 3257 Cube Number 简单数学

SDUT 2021 Spring Individual Contest(for 20) - 14(补题)

Java练习 SDUT-1239_水仙花数

SDUT 3364 数据结构实验之图论八:欧拉回路

SDUT 3038迷之博弈

sdut 1309 —— 不老的传说问题