HDU 5054 Alice and Bob(数学)

Posted zhchoutai

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了HDU 5054 Alice and Bob(数学)相关的知识,希望对你有一定的参考价值。

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5054



Problem Description
Bob and Alice got separated in the Square, they agreed that if they get separated, they‘ll meet back at the coordinate point (x, y). Unfortunately they forgot to define the origin of coordinates and the coordinate axis direction. Now, Bob in the lower left corner of the Square, Alice in the upper right corner of the the Square. Bob regards the lower left corner as the origin of coordinates, rightward for positive direction of axis X, upward for positive direction of axis Y. Alice regards the upper right corner as the origin of coordinates, leftward for positive direction of axis X, downward for positive direction of axis Y. Assuming that Square is a rectangular, length and width size is N * M. As shown in the figure:
技术分享

Bob and Alice with their own definition of the coordinate system respectively, went to the coordinate point (x, y). Can they meet with each other ?

 
Note: Bob and Alice before reaching its destination, can not see each other because of some factors (such as buildings, time poor).

 
Input
There are multiple test cases. Please process till EOF. Each test case only contains four integers : N, M and x, y. The Square size is N * M, and meet in coordinate point (x, y). ( 0 < x < N <= 1000 , 0 < y < M <= 1000 ).
 
Output
If they can meet with each other, please output "YES". Otherwise, please output "NO".
 
Sample Input
10 10 5 5 10 10 6 6
 
Sample Output
YES NO
 
Source


官方题解:

技术分享


代码例如以下:

#include <cstdio>
int main()
{
    int n, m;
    int x, y;
    while(~scanf("%d%d%d%d",&n,&m,&x,&y))
    {
        if(x*2==n && y*2==m)
            printf("YES\n");
        else
            printf("NO\n");
    }
    return 0;
}













以上是关于HDU 5054 Alice and Bob(数学)的主要内容,如果未能解决你的问题,请参考以下文章

Alice and Bob HDU - 4111 (SG函数)

Alice and Bob——hdu4111

codeforces_346A Alice and Bob(数学)

UVA1484 Alice and Bob's Trip (hdu3660)

Codeforce 346A. Alice and Bob

Codeforce 346A. Alice and Bob