Num 36 : ZOJ 2100 [ 深度优先搜索算法 ] [ 回溯 ]

Posted blfbuaa

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了Num 36 : ZOJ 2100 [ 深度优先搜索算法 ] [ 回溯 ]相关的知识,希望对你有一定的参考价值。



        该题是用回溯法来解决的题:


题目:

Seeding

Time Limit: 2 Seconds      Memory Limit: 65536 KB

It is spring time and farmers have to plant seeds in the field. Tom has a nice field,which is a rectangle with n * m squares. There are big stones in some of the squares.

Tom has a seeding-machine. At the beginning, the machine lies in the top left corner of the field. After the machine finishes one square, Tom drives it into an adjacent square, and continues seeding. In order to protect the machine, Tom will not drive it into a square that contains stones. It is not allowed to drive the machine into a square that been seeded before, either.

Tom wants to seed all the squares that do not contain stones. Is it possible?


Input

The first line of each test case contains two integers n and m that denote the size of the field. (1 < n, m < 7) The next n lines give the field, each of which contains m characters. ‘S‘ is a square with stones, and ‘.‘ is a square without stones.

Input is terminated with two 0‘s. This case is not to be processed.


Output

For each test case, print "YES" if Tom can make it, or "NO" otherwise.


Sample Input

4 4
.S..
.S..
....
....
4 4
....
...S
....
...S
0 0


Sample Output

YES
NO


         题目大意:

             从左上角開始行进,能不能不走回头路的把地图上全部点走一遍;( S代表障碍物 )。


         题目分析:

             从左上角開始,利用回溯法进行深搜。推断有没有一种情况。能不回头的把一条路走完;


AC代码:

#include<stdio.h>
#include<stdlib.h>
#include<string.h>
int x,y,m,n,snum,max=0,flag;
char map[10][10];
void fun(int x,int y)
{
	if(x<1||x>m||y<1||y>n) return;
    if(map[x][y]==‘S‘) return;
    if(flag==1) return;
	map[x][y]=‘S‘;
	snum++;
	if(snum==m*n)
    {
    	flag=1;
    	return;
    }
	fun(x-1,y);
	fun(x+1,y);
	fun(x,y-1);
	fun(x,y+1);
	snum--;
	map[x][y]=‘.‘;
}
int main()
{
	int i,j;
	while(scanf("%d%d",&m,&n),m|n)
	{
		snum=0;
		for(i=1;	i<=m;	i++)
			for(j=1;	j<=n;	j++)
			{
				scanf(" %c",&map[i][j]);
				if(map[i][j]==‘S‘) snum++;
			}
		flag=0;
		fun(1,1);
		if(flag) printf("YES\n");
		else printf("NO\n");
	}
	return 0;
}



以上是关于Num 36 : ZOJ 2100 [ 深度优先搜索算法 ] [ 回溯 ]的主要内容,如果未能解决你的问题,请参考以下文章

Oil Deposits (poj 1241) 搜索 (深度优先搜素)

Zoj 2100 Seeding

算法题——深度优先搜索与广度优先搜索

使用广度优先搜素查找路径

数据结构—— 图:图的遍历

ZOJ 1004 Anagrams by Stack