Red and Black

Posted

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了Red and Black相关的知识,希望对你有一定的参考价值。

Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can‘t move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.
 

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

‘.‘ - a black tile
‘#‘ - a red tile
‘@‘ - a man on a black tile(appears exactly once in a data set)
 

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).
 

Sample Input

6 9 ....#. .....# ...... ...... ...... ...... ...... #@...# .#..#. 11 9 .#......... .#.#######. .#.#.....#. .#.#.###.#. .#.#[email protected]#.#. .#.#####.#. .#.......#. .#########. ........... 11 6 ..#..#..#.. ..#..#..#.. ..#..#..### ..#..#..#@. ..#..#..#.. ..#..#..#.. 7 7 ..#.#.. ..#.#.. ###.### [email protected] ###.### ..#.#.. ..#.#.. 0 0
 

Sample Output

45 59 6 13
 
 
 
 
#include<stdio.h>
int w,h;
char a[100][100];
int find(int x,int y)
{
      if(x<0||x>=h||y<0||y>=w)
          return 0;
      if(a[x][y]==‘#‘)
          return 0;
      else
      {
          a[x][y]=‘#‘;
          return 1+find(x+1,y)+find(x-1,y)+find(x,y-1)+find(x,y+1);
      }
}
int main()
{
    int i,j;
    while(scanf("%d%d",&w,&h)!=-1)
    {
        getchar();
        for(i=0;i<h;i++)
            scanf("%s",a[i]);
        for(i=0;i<h;i++)
            for(j=0;j<w;j++) if(a[i][j]==‘@‘)
                    printf("%d\n",find(i,j));
    }
    return 0;
}

  

以上是关于Red and Black的主要内容,如果未能解决你的问题,请参考以下文章

1312 Red and Black

Red and Black(dfs水)

Red and Black

Red and Black

[dfs] [FloodFill] POJ1979 Red And Black

HDU - 1312 : Red and Black