poj 2503 Babelfish(字典树或着STL)

Posted

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了poj 2503 Babelfish(字典树或着STL)相关的知识,希望对你有一定的参考价值。

Babelfish
Time Limit: 3000MS   Memory Limit: 65536K
Total Submissions: 35828   Accepted: 15320

Description

You have just moved from Waterloo to a big city. The people here speak an incomprehensible dialect of a foreign language. Fortunately, you have a dictionary to help you understand them.

Input

Input consists of up to 100,000 dictionary entries, followed by a blank line, followed by a message of up to 100,000 words. Each dictionary entry is a line containing an English word, followed by a space and a foreign language word. No foreign word appears more than once in the dictionary. The message is a sequence of words in the foreign language, one word on each line. Each word in the input is a sequence of at most 10 lowercase letters.

Output

Output is the message translated to English, one word per line. Foreign words not in the dictionary should be translated as "eh".

Sample Input

dog ogday
cat atcay
pig igpay
froot ootfray
loops oopslay

atcay
ittenkay
oopslay

Sample Output

cat
eh
loops

Hint

Huge input and output,scanf and printf are recommended.

Source

Waterloo local 2001.09.22




STL相同秒杀 我就怀疑字典树有个鸡毛用,測试例子太少了吧!


STL:

#include<iostream>
#include<sstream>
#include<algorithm>
#include<cstdio>
#include<string.h>
#include<cctype>
#include<string>
#include<cmath>
#include<vector>
#include<stack>
#include<queue>
#include<map>
#include<set>
using namespace std;

int main()
{
    string str;map<string,string >cnt;
    while(getline(cin,str)&&str[0]!=0)
    {
        int loc=str.find(" ");
        cnt[str.substr(loc+1,str.size()-loc-1)]=str.substr(0,loc);
    }
    while(cin>>str)
    {
        if(cnt.count(str))
            cout<<cnt[str]<<endl;
        else
            cout<<"eh"<<endl;
    }
    return 0;
}

字典树:

#include<iostream>
#include<sstream>
#include<algorithm>
#include<cstdio>
#include<string.h>
#include<cctype>
#include<string>
#include<cmath>
#include<vector>
#include<stack>
#include<queue>
#include<map>
#include<set>
using namespace std;
typedef struct NodeType
{
    struct NodeType * child[26];
    char word [11];
    int isWord;
    NodeType()
    {
        memset(child,NULL,sizeof(child));
        isWord=0;
    }
} Node;

void insertWord(Node *node,char *wo,char *wt)
{
    int id;
    while(*wt)
    {
        id=*wt-‘a‘;
        if(node->child[id]==NULL)
            node->child[id]=new Node();
        node=node->child[id];
        wt++;
    }
    node->isWord=1;
    strcpy(node->word,wo);
}

char * searchWord(Node * node,char *wd)
{
    char *noWord="eh";
    int id;
    while(*wd)
    {
        id=*wd-‘a‘;
        if(node->child[id]==NULL)
            return noWord;
        node=node->child[id];
        wd++;
    }
    if(node->isWord)
        return node->word;
    else
        return noWord;
}

int main()
{
    char cnt[40],dict[40],buf[40];
    Node * node=new Node;
    while(gets(buf)&&buf[0]!=0)
    {
        int i=0;
        for(; buf[i]!=32; i++)
            cnt[i]=buf[i];
        cnt[i]=0;
        int j;
        for(++i,j=0; buf[i]; i++,j++)
            dict[j]=buf[i];
        dict[j]=0;
        insertWord(node,cnt,dict);
    }
    while(scanf("%s",cnt)!=EOF)
    {
        char *word = searchWord(node,cnt);
        printf("%s\n",word);
    }
    return 0;
}


以上是关于poj 2503 Babelfish(字典树或着STL)的主要内容,如果未能解决你的问题,请参考以下文章

POJ2503 Babelfish

POJ-2503 Babelfish---map或者hash

POJ 2503.Babelfish

Babelfish POJ - 2503

POJ 2503 Babelfish

poj 2503 Babelfish