HDUJ 2052 Picture 模拟

Posted jzssuanfa

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了HDUJ 2052 Picture 模拟相关的知识,希望对你有一定的参考价值。

Picture

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 15932    Accepted Submission(s): 8240


Problem Description
Give you the width and height of the rectangle,darw it.
 

Input
Input contains a number of test cases.For each case ,there are two numbers n and m (0 < n,m < 75)indicate the width and height of the rectangle.Iuput ends of EOF.
 

Output
For each case,you should draw a rectangle with the width and height giving in the input.
after each case, you should a blank line.
 

Sample Input
3 2
 

Sample Output
+---+ | | | | +---+



#include<iostream>
#include<cstring>
using namespace std;

int main()
{
	int n,m;
	while(cin>>n>>m)
	{
		char str[85][85];
		memset(str,0,sizeof(str));
		int i,j;
		for(i=0;i<=m+1;i++)
		{
			for(j=0;j<=n+1;j++)
			{
				if(i==0 || i==m+1)
					str[i][j]=‘-‘;
				else
					str[i][j]=‘ ‘;
				if(j==0 || j==n+1)
					str[i][j]=‘|‘;
			}
		}

		str[0][0]=str[0][n+1]=str[m+1][0]=str[m+1][n+1]=‘+‘;
		for(i=0;i<=m+1;i++)
		{
			for(j=0;j<=n+1;j++)
				cout<<str[i][j];
			cout<<endl;
		}
		cout<<endl;
	}

	return 0;
}


以上是关于HDUJ 2052 Picture 模拟的主要内容,如果未能解决你的问题,请参考以下文章

HDoj 2052 Picture

HDUJ 2070 Fibbonacci Number

HDUJ 1019 Least Common Multiple

HDUJ 1203 I NEED A OFFER!

Access:collating sort order SortOrder[2052]

CK2052-电子商务网站(模块化布局)实战开发