HDOJ 1049 Climbing Worm

Posted jzdwajue

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了HDOJ 1049 Climbing Worm相关的知识,希望对你有一定的参考价值。

Climbing Worm

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 12116    Accepted Submission(s): 8149


Problem Description
An inch worm is at the bottom of a well n inches deep. It has enough energy to climb u inches every minute, but then has to rest a minute before climbing again. During the rest, it slips down d inches. The process of climbing and resting then repeats. How long before the worm climbs out of the well?

We‘ll always count a portion of a minute as a whole minute and if the worm just reaches the top of the well at the end of its climbing, we‘ll assume the worm makes it out.

 

Input
There will be multiple problem instances. Each line will contain 3 positive integers n, u and d. These give the values mentioned in the paragraph above. Furthermore, you may assume d < u and n < 100. A value of n = 0 indicates end of output.
 

Output
Each input instance should generate a single integer on a line, indicating the number of minutes it takes for the worm to climb out of the well.
 

Sample Input
10 2 1 20 3 1 0 0 0
 

Sample Output
17 19
 



#include<stdio.h>
int main()
{
	int n,u,d;
	while(scanf("%d %d %d",&n,&u,&d),n)
	{
		int t;
		t=(n-u)/(u-d);
		if(t*(u-d)<(n-u)) t++;
		t*=2;
		t++;
		printf("%d\n",t);
	}
	return 0;
}



以上是关于HDOJ 1049 Climbing Worm的主要内容,如果未能解决你的问题,请参考以下文章

P1049 装箱问题

HDOJ:1051

HDOJ4605 Magic Ball Game

1049 ??????????????????(20)???20 ??????

HDOJ1160 Fat Mouse&#39;s Speed

HDOJ 1879 Kruskal实现