HDU 1045 dfs

Posted LuZhiyuan

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了HDU 1045 dfs相关的知识,希望对你有一定的参考价值。

Fire Net

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 11742    Accepted Submission(s): 7048


Problem Description
Suppose that we have a square city with straight streets. A map of a city is a square board with n rows and n columns, each representing a street or a piece of wall. 

A blockhouse is a small castle that has four openings through which to shoot. The four openings are facing North, East, South, and West, respectively. There will be one machine gun shooting through each opening. 

Here we assume that a bullet is so powerful that it can run across any distance and destroy a blockhouse on its way. On the other hand, a wall is so strongly built that can stop the bullets. 

The goal is to place as many blockhouses in a city as possible so that no two can destroy each other. A configuration of blockhouses is legal provided that no two blockhouses are on the same horizontal row or vertical column in a map unless there is at least one wall separating them. In this problem we will consider small square cities (at most 4x4) that contain walls through which bullets cannot run through. 

The following image shows five pictures of the same board. The first picture is the empty board, the second and third pictures show legal configurations, and the fourth and fifth pictures show illegal configurations. For this board, the maximum number of blockhouses in a legal configuration is 5; the second picture shows one way to do it, but there are several other ways. 

技术分享

Your task is to write a program that, given a description of a map, calculates the maximum number of blockhouses that can be placed in the city in a legal configuration. 
 

 

Input
The input file contains one or more map descriptions, followed by a line containing the number 0 that signals the end of the file. Each map description begins with a line containing a positive integer n that is the size of the city; n will be at most 4. The next n lines each describe one row of the map, with a ‘.‘ indicating an open space and an uppercase ‘X‘ indicating a wall. There are no spaces in the input file. 
 

 

Output
For each test case, output one line containing the maximum number of blockhouses that can be placed in the city in a legal configuration.
 

 

Sample Input
4
.X..
....
XX..
....
2
XX
.X
3
.X.
X.X
.X.
3
...
.XX
.XX
4
....
....
....
....
0
 

 

Sample Output
5 1 5 2 4
 

 

Source
 

 题意:

最大4*4的棋盘,X表示该点不能放棋子,每行每列只能放1个棋子除非中间有X把他们隔开,问最多能放几个棋子

代码:

//显然dfs。
#include<iostream>
#include<cstdio>
#include<cstring>
#include<queue>
using namespace std;
int n,vis[5][5],ans;
char mp[5][5];
void change(int x,int y,int p){
    for(int i=x;i<n;i++){
        if(mp[i][y]==X) break;
        vis[i][y]+=p;
    }
    for(int i=x;i>=0;i--){
        if(mp[i][y]==X) break;
        vis[i][y]+=p;
    }
    for(int i=y;i<n;i++){
        if(mp[x][i]==X) break;;
        vis[x][i]+=p;
    }
    for(int i=y;i>=0;i--){
        if(mp[x][i]==X) break;
        vis[x][i]+=p;
    }
}
void dfs(int sum){
    ans=max(ans,sum);
    for(int i=0;i<n;i++){
        for(int j=0;j<n;j++){
            if(mp[i][j]==X||vis[i][j]>0) continue;
            change(i,j,1);
            dfs(sum+1);
            change(i,j,-1);
        }
    }
}
int main()
{
    while(scanf("%d",&n)&&n){
        for(int i=0;i<n;i++) scanf("%s",mp[i]);
        ans=0;
        memset(vis,0,sizeof(vis));
        dfs(0);
        printf("%d\n",ans);
    }
    return 0;
}

 

以上是关于HDU 1045 dfs的主要内容,如果未能解决你的问题,请参考以下文章

hdu1045 DFS

HDU - 1045 Fire Net (dfs 或 二分图)

HDOJ1045DFS

连接MySQL出现错误:ERROR 1045 (28000): Access denied for user ‘root‘@‘localhost‘ (using password: YES)(代码片段

ACM--DFS--最大碉堡数--HDOJ 1045--Fire Net

hdu 1045