最低位 杭电-HDOJ-1196 附题

Posted mthoutai

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了最低位 杭电-HDOJ-1196 附题相关的知识,希望对你有一定的参考价值。

/*
Lowest Bit
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7775    Accepted Submission(s): 5714


Problem Description
Given an positive integer A (1 <= A <= 100), output the lowest bit of A.

For example, given A = 26, we can write A in binary form as 11010, so the lowest bit of A is 10, so the output should be 2.

Another example goes like this: given A = 88, we can write A in binary form as 1011000, so the lowest bit of A is 1000, so the output should be 8.

Input
Each line of input contains only an integer A (1 <= A <= 100). A line containing "0" indicates the end of input, and this line is not a part of the input data.

Output
For each A in the input, output a line containing only its lowest bit.
Sample Input
26
88
0

Sample Output
2
8

#include<stdio.h>
#include<string.h>
int main()
{
	int n;
	while(~scanf("%d",&n),n)
	{
		//printf("%d\n",n&(-n));
		printf("%d\n",n^(n&(n-1)));
	}
	return 0;
}


以上是关于最低位 杭电-HDOJ-1196 附题的主要内容,如果未能解决你的问题,请参考以下文章

大菲波数 杭电-HDOJ-1715 附题+具体解释

最小公倍数 杭电-HDOJ-1108 附题+具体解释

夜深人静写题解--杭电第四场

华为OD机试真题Java实现最低位排序真题+解题思路+代码(2022&2023)

LCT总结——应用篇(附题单)(LCT)

在 Python 中读取最低有效位