hdu 1829 &poj 2492 A Bug's Life(推断二分图带权并查集)

Posted yangykaifa

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了hdu 1829 &poj 2492 A Bug's Life(推断二分图带权并查集)相关的知识,希望对你有一定的参考价值。

A Bug‘s Life

Time Limit: 15000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 8528    Accepted Submission(s): 2745


Problem Description
Background 
Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs. 

Problem 
Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.
 

Input
The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.
 

Output
The output for every scenario is a line containing "Scenario #i:", where i is the number of the scenario starting at 1, followed by one line saying either "No suspicious bugs found!" if the experiment is consistent with his assumption about the bugs‘ sexual behavior, or "Suspicious bugs found!" if Professor Hopper‘s assumption is definitely wrong.
 

Sample Input
2 3 3 1 2 2 3 1 3 4 2 1 2 3 4
 

Sample Output
Scenario #1: Suspicious bugs found! Scenario #2: No suspicious bugs found!
Hint
Huge input,scanf is recommended.


利用黑白染色,推断是否是二分图。

#include"stdio.h"
#include"string.h"
#include"queue"
using namespace std;
#define N 2005
#define M 1000005
int n,m,t,head[N];
int color[N],flag;
struct node
{
    int u,v,next;
}map[2*M];
void add(int u,int v)
{
    map[t].u=u;
    map[t].v=v;
    map[t].next=head[u];
    head[u]=t++;
    map[t].u=v;
    map[t].v=u;
    map[t].next=head[v];
    head[v]=t++;
}
void find(int u)
{
    int i,v;
    for(i=head[u];i!=-1;i=map[i].next)
    {
        v=map[i].v;
        if(color[v]==-1)
        {
            color[v]=color[u]^1;
            find(v);
        }
        else if(color[v]==color[u])
        {
            flag=1;
            return ;
        }
    }
    return ;
}
int main()
{
    int i,T,u,v,cnt=1;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d",&n,&m);
        t=0;
        memset(head,-1,sizeof(head));
        while(m--)
        {
            scanf("%d%d",&u,&v);
            add(u,v);
        }
        memset(color,-1,sizeof(color));
        flag=0;
        for(i=1;i<=n;i++)
        {
            if(color[i]==-1)
            {
                color[i]=0;
                find(i);
                if(flag)
                    break;
            }
        }
        printf("Scenario #%d:\n",cnt++);
        if(flag)
            printf("Suspicious bugs found!\n");
        else
            printf("No suspicious bugs found!\n");
        puts("");
    }
    return 0;
}

带权并查集:

#include"stdio.h"
#include"string.h"
#include"queue"
#include"vector"
#include"stack"
#include"algorithm"
using namespace std;
#define N 2005
#define min(a,b) (a<b?a:b)
int pre[N],gen[N];
int find(int k)
{
    if(k==pre[k])
        return k; 
    int t=find(pre[k]);     //不能马上更新父节点与根节点同样
    gen[k]=gen[k]^gen[pre[k]];//由于该节点的性别和它的父节点相反
    return pre[k]=t;  //确定该点性别之后才干把该点父节点更新为根节点
}
int Union(int x,int y)
{
    int a,b;
    a=find(x);
    b=find(y);
    if(a==b)       //x,y的根节点同样
    {
        if(gen[x]==gen[y]) //推断他们是否同性别
            return 1;
        return 0;
    }
    pre[a]=b;
    gen[a]=(gen[x]+gen[y]+1)&1;
    return 0;
}
int main()
{
    int i,u,v,n,cnt=1,T,m;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d",&n,&m);
        for(i=0;i<=n;i++)
            pre[i]=i;
        memset(gen,0,sizeof(gen));
        int flag=0;
        while(m--)
        {
            scanf("%d%d",&u,&v);
            if(flag)
                continue;
            flag=Union(u,v);
        }
        printf("Scenario #%d:\n",cnt++);
        if(flag)
            printf("Suspicious bugs found!\n");
        else
            printf("No suspicious bugs found!\n");
        puts("");
    }
    return 0;
}



以上是关于hdu 1829 &amp;poj 2492 A Bug&#39;s Life(推断二分图带权并查集)的主要内容,如果未能解决你的问题,请参考以下文章

hdu1501&amp;&amp;poj2192 Zipper(DFS)

poj2243 &amp;&amp; hdu1372 Knight Moves(BFS)

扫描线三巨头 hdu1928&&hdu 1255 && hdu 1542 [POJ 1151]

POJ 3486 &amp; HDU 1913 Computers(dp)

POJ 3923 &amp; HDU 2487 Ugly Windows(模拟)

POJ 3344 &amp; HDU 2414 Chessboard Dance(模拟)