hdoj 1025 Constructing Roads In JGShining's Kingdom 最长递增子序列

Posted ljbguanli

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了hdoj 1025 Constructing Roads In JGShining's Kingdom 最长递增子序列相关的知识,希望对你有一定的参考价值。

Constructing Roads In JGShining\'s Kingdom

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 16262    Accepted Submission(s): 4633


Problem Description
JGShining\'s kingdom consists of 2n(n is no more than 500,000) small cities which are located in two parallel lines.

Half of these cities are rich in resource (we call them rich cities) while the others are short of resource (we call them poor cities). Each poor city is short of exactly one kind of resource and also each rich city is rich in exactly one kind of resource. You may assume no two poor cities are short of one same kind of resource and no two rich cities are rich in one same kind of resource.

With the development of industry, poor cities wanna import resource from rich ones. The roads existed are so small that they\'re unable to ensure the heavy trucks, so new roads should be built. The poor cities strongly BS each other, so are the rich ones. Poor cities don\'t wanna build a road with other poor ones, and rich ones also can\'t abide sharing an end of road with other rich ones. Because of economic benefit, any rich city will be willing to export resource to any poor one.

Rich citis marked from 1 to n are located in Line I and poor ones marked from 1 to n are located in Line II.

The location of Rich City 1 is on the left of all other cities, Rich City 2 is on the left of all other cities excluding Rich City 1, Rich City 3 is on the right of Rich City 1 and Rich City 2 but on the left of all other cities ... And so as the poor ones.

But as you know, two crossed roads may cause a lot of traffic accident so JGShining has established a law to forbid constructing crossed roads.

For example, the roads in Figure I are forbidden.



In order to build as many roads as possible, the young and handsome king of the kingdom - JGShining needs your help, please help him. ^_^
 

Input
Each test case will begin with a line containing an integer n(1 ≤ n ≤ 500,000). Then n lines follow. Each line contains two integers p and r which represents that Poor City p needs to import resources from Rich City r. Process to the end of file.
 

Output
For each test case, output the result in the form of sample.
You should tell JGShining what\'s the maximal number of road(s) can be built.
 

Sample Input
2 1 2 2 1 3 1 2 2 3 3 1
 

Sample Output
Case 1: My king, at most 1 road can be built. Case 2: My king, at most 2 roads can be built.
Hint
Huge input, scanf is recommended.

分析:传统的o(n2)的肯定会超时,所以用一种O(nlgn)的算法。主要是用了二分查找。。

关于这样的算法http://www.cnblogs.com/dongsheng/archive/2013/01/25/2876323.html这个讲的非常好。

代码:

#include <stdio.h>
#include <string.h>
#include <algorithm>
#define  M 500005
using namespace std;

struct node{
    int p, r;
}s[M];
int d[M];

int cmp(node a, node b){
    return a.p<b.p;
}


int bis(int s, int len){
    int right = len, left = 0, mid;
    while(left <= right){
        mid = (left+right)>>1;
        if(d[mid]>s) right = mid-1;
        else if(d[mid] < s) left = mid+1;
        else return mid;
    }
    return left;
}
int main(){
    int n, v=1;
    while(scanf("%d", &n) == 1){
        memset(d, 0, sizeof(d));
        int i, len;
        for(i = 0; i < n; i ++)
            scanf("%d%d", &s[i].p, &s[i].r);
        sort(s, s+n, cmp);
        len = 1;
        d[len] = s[0].r;
        for(i = 1; i < n; i ++){
            int t = bis(s[i].r, len);
            d[t] = s[i].r;
            if(t > len)
                len++;
        }
        printf("Case %d:\\n", v++);
        printf("My king, at most %d road", len);
        if(len > 1) printf("s");
        printf(" can be built.\\n\\n");
    }
    return 0;
}



以上是关于hdoj 1025 Constructing Roads In JGShining&#39;s Kingdom 最长递增子序列的主要内容,如果未能解决你的问题,请参考以下文章

Constructing Roads In JGShining's Kingdom HDU - 1025

HDU 1025 Constructing Roads In JGShining's Kingdom

hdu-1025 Constructing Roads In JGShining's Kingdom(二分查找)

HDU 1025:Constructing Roads In JGShining's Kingdom(LIS+二分优化)

Hdoj 1102.Constructing Roads 题解

hdu1025 Constructing Roads In JGShining&#39;s Kingdom(二分+dp)