UVA 12034 Race (递推神马的)

Posted liguangsunls

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了UVA 12034 Race (递推神马的)相关的知识,希望对你有一定的参考价值。

Disky and Sooma, two of the biggest mega minds of Bangladesh went to a far country. They ate, coded and wandered around, even in their holidays. They passed several months in this way. But everything has an end. A holy person, Munsiji came into their life. Munsiji took them to derby (horse racing). Munsiji enjoyed the race, but as usual Disky and Sooma did their as usual task instead of passing some romantic moments. They were thinking- in how many ways a race can finish! Who knows, maybe this is their romance!

In a race there are n horses. You have to output the number of ways the race can finish. Note that, more than one horse may get the same position. For example, 2 horses can finish in 3 ways.

  1. Both first
  2. horse1 first and horse2 second
  3. horse2 first and horse1 second

Input 

Input starts with an integer T (技术分享1000), denoting the number of test cases. Each case starts with a line containing an integer n ( 1技术分享n技术分享1000).

Output 

For each case, print the case number and the number of ways the race can finish. The result can be very large, print the result modulo 10056.

Sample Input 

3
1
2
3

Sample Output 

Case 1: 1
Case 2: 3
Case 3: 13
对,又是递推题目:我们dp[i][j]表示i个马,分j次到达的方法;
考虑状态转移:dp[i][j]=j*(dp[i-1][j](第i个马和前面的马搭伙到达)+dp[i-1][j-1](第i个马单独算一次))
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<limits.h>
typedef long long LL;
using namespace std;
const int MOD=10056;
int dp[1100][1100];
int ans[1100];
void init()
{
    memset(dp,0,sizeof(dp));
    memset(ans,0,sizeof(ans));
    dp[0][0]=1;
    for(int i=1;i<=1000;i++)
    {
        int sum=0;
        for(int j=1;j<=i;j++)
        {
            dp[i][j]+=(dp[i-1][j]+dp[i-1][j-1])%MOD*j%MOD;//小心心爆int
            sum=(sum%MOD+dp[i][j])%MOD;
        }
        ans[i]=sum;
    }
}
int main()
{
    init();
    int n,t;
    int cas=1;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        printf("Case %d: %d\n",cas++,ans[n]);
    }
    return 0;
}




以上是关于UVA 12034 Race (递推神马的)的主要内容,如果未能解决你的问题,请参考以下文章

UVA 12034 Race

[UVA - 12034] Race 题解

uva 12034 Race

UVa 12034 比赛名次(递推)

UVA 12034(递推&递归_I题)解题报告

Uva12034 (组合数取模)