hdu 2147 kiki's game

Posted 日拱一卒 功不唐捐

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了hdu 2147 kiki's game相关的知识,希望对你有一定的参考价值。

kiki‘s game

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 40000/10000 K (Java/Others)
http://acm.hdu.edu.cn/showproblem.php?pid=2147


Problem Description
Recently kiki has nothing to do. While she is bored, an idea appears in his mind, she just playes the checkerboard game.The size of the chesserboard is n*m.First of all, a coin is placed in the top right corner(1,m). Each time one people can move the coin into the left, the underneath or the left-underneath blank space.The person who can‘t make a move will lose the game. kiki plays it with ZZ.The game always starts with kiki. If both play perfectly, who will win the game?
 
Input
Input contains multiple test cases. Each line contains two integer n, m (0<n,m<=2000). The input is terminated when n=0 and m=0.

Output
If kiki wins the game printf "Wonderful!", else "What a pity!".
 
Sample Input
5 3 5 4 6 6 0 0
 
Sample Output
What a pity!
Wonderful!
Wonderful!
结论:
若n和m都是奇数,则先手败
否则,先手胜
从1*1,1*2,2*1,2*2一步一步推即可得出
#include<cstdio>
using namespace std;
int main()
{
    int n,m;
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        if(!n) return 0;
        if(n%2&&m%2) printf("What a pity!\n");
        else printf("Wonderful!\n");
    }
}

 

 

以上是关于hdu 2147 kiki's game的主要内容,如果未能解决你的问题,请参考以下文章

HDU 2147 kiki's game

hdu 2147 kiki's game(找规律)

HDU 2147 kiki's game(规律,博弈)

hdu2147 kiki&#39;s game(博弈)

HDU 2147 kiki's game(博弈图上找规律)

HDU 1564 Play a game && HDU 2147 kiki's game