[USACO07DEC]手链Charm Bracelet——01背包

Posted

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了[USACO07DEC]手链Charm Bracelet——01背包相关的知识,希望对你有一定的参考价值。

题目描述

Bessie has gone to the mall‘s jewelry store and spies a charm bracelet. Of course, she‘d like to fill it with the best charms possible from the N (1 ≤ N ≤ 3,402) available charms. Each charm i in the supplied list has a weight Wi (1 ≤ Wi ≤ 400), a ‘desirability‘ factor Di (1 ≤ Di ≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than M (1 ≤ M ≤ 12,880).

Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.

有N件物品和一个容量为V的背包。第i件物品的重量是c[i],价值是w[i]。求解将哪些物品装入背包可使这些物品的重量总和不超过背包容量,且价值总和最大。

输入输出格式

输入格式:

 

  • Line 1: Two space-separated integers: N and M

  • Lines 2..N+1: Line i+1 describes charm i with two space-separated integers: Wi and Di

 

输出格式:

 

  • Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints

 

输入输出样例

输入样例#1:
4 6
1 4
2 6
3 12
2 7
输出样例#1:
23


代码
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
int n,v,c[3403],d[3403],f[1000000];
int main()
{
    scanf("%d%d",&n,&v);
    for(int i=1;i<=n;i++)
    {
        scanf("%d%d",&d[i],&c[i]);
    }
    for(int i=1;i<=n;i++)
      for(int m=v;m>=d[i];m--)
        f[m]=max(f[m],f[m-d[i]]+c[i]);
    printf("%d",f[v]);
    return 0;
}

 

 

以上是关于[USACO07DEC]手链Charm Bracelet——01背包的主要内容,如果未能解决你的问题,请参考以下文章

P2871 [USACO07DEC]手链Charm Bracelet

锣鼓P2871 [USACO07DEC]手链Charm Bracelet

bzoj1625 / P2871 [USACO07DEC]手链Charm Bracelet

洛谷——P2871 [USACO07DEC]手链Charm Bracelet

luogu P2871 [USACO07DEC]手链Charm Bracelet

洛谷 P2871 [USACO07DEC]手链Charm Bracelet 题解