干草出售Hay For Sale

Posted

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了干草出售Hay For Sale相关的知识,希望对你有一定的参考价值。

题目描述

Farmer John suffered a terrible loss when giant Australian cockroaches ate the entirety of his hay inventory, leaving him with nothing to feed the cows. He hitched up his wagon with capacity C (1 <= C <= 50,000) cubic units and sauntered over to Farmer Don‘s to get some hay before the cows miss a meal.

Farmer Don had a wide variety of H (1 <= H <= 5,000) hay bales for sale, each with its own volume (1 <= V_i <= C). Bales of hay, you know, are somewhat flexible and can be jammed into the oddest of spaces in a wagon.

FJ carefully evaluates the volumes so that he can figure out the largest amount of hay he can purchase for his cows.

Given the volume constraint and a list of bales to buy, what is the greatest volume of hay FJ can purchase? He can‘t purchase partial bales, of course. Each input line (after the first) lists a single bale FJ can buy.

约翰遭受了重大的损失:蟑螂吃掉了他所有的干草,留下一群饥饿的牛.他乘着容量为C(1≤C≤50000)个单位的马车,去顿因家买一些干草. 顿因有H(1≤H≤5000)包干草,每一包都有它的体积Vi(l≤Vi≤C).约翰只能整包购买,

他最多可以运回多少体积的干草呢?

输入输出格式

输入格式:

 

  • Line 1: Two space-separated integers: C and H

  • Lines 2..H+1: Each line describes the volume of a single bale: V_i

 

输出格式:

 

  • Line 1: A single integer which is the greatest volume of hay FJ can purchase given the list of bales for sale and constraints.

 

输入输出样例

输入样例#1:
7 3 
2 
6 
5 
输出样例#1:
7 

说明

The wagon holds 7 volumetric units; three bales are offered for sale with volumes of 2, 6, and 5 units, respectively.

Buying the two smaller bales fills the wagon.

 

 

代码

#include <algorithm>
#include <cstdio>

using namespace std;

int n,v,w[50000];
int f[500000];

int main()
{
    scanf("%d%d",&v,&n);
    for(int i=1;i<=n;i++)
        scanf("%d",&w[i]);
    for(int i=1;i<=n;i++)
        for(int m=v;m>=w[i];m--)
            if(f[m-w[i]]+w[i]>f[m])
                f[m]=f[m-w[i]]+w[i];
    printf("%d",f[v]);
    return 0;
}

 

以上是关于干草出售Hay For Sale的主要内容,如果未能解决你的问题,请参考以下文章

洛谷P2925 [USACO08DEC]干草出售Hay For Sale

洛谷P2925 [USACO08DEC]干草出售Hay For Sale

洛谷P2925 [USACO08DEC]干草出售Hay For Sale

洛谷——P2925 [USACO08DEC]干草出售Hay For Sale

AC日记——[USACO08DEC]干草出售Hay For Sale 洛谷 P2925

P2925 [USACO08DEC]干草出售Hay For Sale 题解