[poj2234] Matches Game

Posted AronQi

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了[poj2234] Matches Game相关的知识,希望对你有一定的参考价值。

Description

Here is a simple game. In this game, there are several piles of matches and two players. The two player play in turn. In each turn, one can choose a pile and take away arbitrary number of matches from the pile (Of course the number of matches, which is taken away, cannot be zero and cannot be larger than the number of matches in the chosen pile). If after a player’s turn, there is no match left, the player is the winner. Suppose that the two players are all very clear. Your job is to tell whether the player who plays first can win the game or not.

Input

The input consists of several lines, and in each line there is a test case. At the beginning of a line, there is an integer M (1 <= M <=20), which is the number of piles. Then comes M positive integers, which are not larger than 10000000. These M integers represent the number of matches in each pile.

Output

For each test case, output "Yes" in a single line, if the player who play first will win, otherwise output "No".

Sample Input

2 45 45
3 3 6 9

Sample Output

No
Yes
Solution

Nim游戏,直接异或
#include <stdio.h>
int n, ans, x;
int main()
	{
	while(~scanf("%d", &n))
		{
		ans = 0;
		for(register int i = 0; i < n; i++) scanf("%d", &x), ans ^= x;
		if(ans) putchar(‘Y‘), putchar(‘e‘), putchar(‘s‘), putchar(‘\n‘);
		else putchar(‘N‘), putchar(‘o‘), putchar(‘\n‘);
		}
	return 0;
	}

 

以上是关于[poj2234] Matches Game的主要内容,如果未能解决你的问题,请参考以下文章

[poj2234] Matches Game

poj 2234 Matches Game

POJ 2234 Matches Game(Nim博弈裸题)

POJ 2234 Matches Game(取火柴博弈1)

POJ 2234 Matches Game 尼姆博弈

POJ2234 Matches Game 尼姆博弈 博弈论