Problem A: 类的初体验

Posted 好奇怪的妹妹

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了Problem A: 类的初体验相关的知识,希望对你有一定的参考价值。

Description

定义一个类Data,只有一个double类型的属性和如下3个方法:
1.    void init(double d);——初始化属性值。

2.   double getValue()——获得属性值。

3.    void showValue()——显示属性值。

Input

一个double类型的数值。

Output

输出输入的值2次,每次占一行。

Sample Input

3.14

Sample Output

3.14 3.14

HINT

Append Code

int main()
{
    Data data;
    double d;
    cin>>d;
    data.init(d);
    cout<<data.getValue()<<endl;
    data.showValue();
}
 
代码
 
#include <iostream>
#include <iomanip>
using namespace std;

class Data
{
    private:
    double a;
    public:
        void init(double d)
        {
            a=d;
        }
        double getValue()
        {
            return a;
        }
        void showValue()
        {
            cout<<a<<endl;
        }
};
int main()
{
    Data data;
    double d;
    cin>>d;
    data.init(d);
    cout<<data.getValue()<<endl;
    data.showValue();
}

以上是关于Problem A: 类的初体验的主要内容,如果未能解决你的问题,请参考以下文章

Problem C: 类的初体验(III)

Problem D: 类的初体验(IV)

Problem B: 类的初体验(II)

python的初体验

Objective-C Runtime的基本使用(iOS Runtime的初体验)

android studio下百度地图sdk的初体验