Buy the souvenirs (01背包,动归)

Posted

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了Buy the souvenirs (01背包,动归)相关的知识,希望对你有一定的参考价值。

When the winter holiday comes, a lot of people will have a trip. Generally, there are a lot of souvenirs to sell, and sometimes the travelers will buy some ones with pleasure. Not only can they give the souvenirs to their friends and families as gifts, but also can the souvenirs leave them good recollections. All in all, the prices of souvenirs are not very dear, and the souvenirs are also very lovable and interesting. But the money the people have is under the control. They can’t buy a lot, but only a few. So after they admire all the souvenirs, they decide to buy some ones, and they have many combinations to select, but there are no two ones with the same kind in any combination. Now there is a blank written by the names and prices of the souvenirs, as a top coder all around the world, you should calculate how many selections you have, and any selection owns the most kinds of different souvenirs. For instance:

技术分享


And you have only 7 RMB, this time you can select any combination with 3 kinds of souvenirs at most, so the selections of 3 kinds of souvenirs are ABC (6), ABD (7). But if you have 8 RMB, the selections with the most kinds of souvenirs are ABC (6), ABD (7), ACD (8), and if you have 10 RMB, there is only one selection with the most kinds of souvenirs to you: ABCD (10).

Output
If you can buy some souvenirs, you should print the result with the same formation as “You have S selection(s) to buy with K kind(s) of souvenirs”, where the K means the most kinds of souvenirs you can buy, and S means the numbers of the combinations you can buy with the K kinds of souvenirs combination. But sometimes you can buy nothing, so you must print the result “Sorry, you can‘t buy anything.”
Sample Input
2 4 7 1 2 3 4  4 0 1 2 3 4
Sample Output
You have 2 selection(s) to buy with 3 kind(s) of souvenirs. Sorry, you can‘t buy anything.

Input
For the first line, there is a T means the number cases, then T cases follow.
In each case, in the first line there are two integer n and m, n is the number of the souvenirs and m is the money you have. The second line contains n integers; each integer describes a kind of souvenir.
All the numbers and results are in the range of 32-signed integer, and 0<=m<=500, 0<n<=30, t<=500, and the prices are all positive integers. There is a blank line between two cases.

 

 大意:给定纪念品数目n,价格a[1~n],求m元能购买的最多纪念品数目,以及m元能购买该数目纪念品的组合数。

 

 

 #include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int f[33][505],a[33];
int main()
{
    int t,n,m,k,s;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&m);
        for(int i=1;i<=n;i++)
            scanf("%d",&a[i]);
            memset(f,0,sizeof(f));
        sort(a+1,a+n+1);
        k=n,s=0;
        for(int i=1;i<=n;i++)
        {
            s+=a[i];
            if(s>m)
            {
                k=i-1;
                break;
            }
        }
        for(int i=0;i<=m;i++)
            f[0][i]=1;

        if(k)
        {
               for(int i=1;i<=n;i++)
                for(int j=m;j>=a[i];j--)
                for(int l=1;l<=k;l++)
                f[l][j]+=f[l-1][j-a[i]];
            printf("You have %d selection(s) to buy with %d kind(s) of souvenirs.\n",f[k][m],k);
        }
        else
            printf("Sorry, you can‘t buy anything.\n");
    }
    return 0;
}



















































以上是关于Buy the souvenirs (01背包,动归)的主要内容,如果未能解决你的问题,请参考以下文章

hdu 2126 Buy the souvenirs 输出方案数01背包(经典)

HDU 2126 Buy the souvenirs

习题:Selling Souvenirs(二分)

Codeforces 808 E. Selling Souvenirs(三分)

hdu5543(Pick The Sticks) 01背包

CodeforcesF2. Complete the Projects (hard version) (贪心+贪心+01背包)