POJ3273(最大化问题)

Posted vCoders

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了POJ3273(最大化问题)相关的知识,希望对你有一定的参考价值。

Monthly Expense
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 20603   Accepted: 8101

Description

Farmer John is an astounding accounting wizard and has realized he might run out of money to run the farm. He has already calculated and recorded the exact amount of money (1 ≤ moneyi ≤ 10,000) that he will need to spend each day over the next N (1 ≤ N ≤ 100,000) days.

FJ wants to create a budget for a sequential set of exactly M (1 ≤ M ≤ N) fiscal periods called "fajomonths". Each of these fajomonths contains a set of 1 or more consecutive days. Every day is contained in exactly one fajomonth.

FJ‘s goal is to arrange the fajomonths so as to minimize the expenses of the fajomonth with the highest spending and thus determine his monthly spending limit.

Input

Line 1: Two space-separated integers: N and M 
Lines 2..N+1: Line i+1 contains the number of dollars Farmer John spends on the ith day

Output

Line 1: The smallest possible monthly limit Farmer John can afford to live with.

Sample Input

7 5
100
400
300
100
500
101
400

Sample Output

500
题意:将N个数分成M组,使每组之和的最大值最小。
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int MAXN=100005;
int money[MAXN];
int n,m;
bool judge(int d)
{
    int cnt=1;
    int s=0;
    for(int i=0;i<n;i++)
    {
        if(s+money[i]<=d)
        {
            s+=money[i];
        }
        else{
            cnt++;
            s=money[i];
        }
    }
    
    return cnt <= m;
}
int main()
{
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        int l=0,r=0;
        for(int i=0;i<n;i++)
        {
            scanf("%d",&money[i]);
            r+=money[i];
            l=max(l,money[i]);
        }
        
        while(l<r)
        {
            int mid=(l+r)/2;
            if(judge(mid))//Âú×ãÌõ¼þ,˵Ã÷d>=anserÁË 
                r=mid;
            else l=mid+1;    //dСÁË 
        }        
        printf("%d\n",r);
    }
    
    return 0;
}

 

以上是关于POJ3273(最大化问题)的主要内容,如果未能解决你的问题,请参考以下文章

二分 poj 3273

POJ 3273 Monthly Expense (二分&最大化最小值)

POJ3273-Monthly Expense (最小化最大值)

POJ-3273 Monthly Expense---最小化最大值

Monthly Expense POJ - 3273 (最大值最小化)(二分答案)

POJ 3273 :Monthly Expense二分