P - How many

Posted joeylee97

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了P - How many相关的知识,希望对你有一定的参考价值。

Give you n ( n < 10000) necklaces ,the length of necklace will not large than 100,tell me 
How many kinds of necklaces total have.(if two necklaces can equal by rotating ,we say the two necklaces are some). 
For example 0110 express a necklace, you can rotate it. 0110 -> 1100 -> 1001 -> 0011->0110. 

InputThe input contains multiple test cases. 
Each test case include: first one integers n. (2<=n<=10000) 
Next n lines follow. Each line has a equal length character string. (string only include ‘0‘,‘1‘). 
OutputFor each test case output a integer , how many different necklaces.Sample Input

4
0110
1100
1001
0011
4
1010
0101
1000
0001

Sample Output

1
2
#include<iostream>
#include<set>
#include<map>
#include<vector>
#include<string>
#include<algorithm>
#include<cstring>
using namespace std;
#define MAXN 10002
/*
题目相当于求所有字符串中
能通过相互循环位移得到的字符串数目
对每个字符串求最小表示法,然后加入到set中
*/
string str;
set<string> S;
int GetMin(string s,int len)
{
    int i=0,j=1,k=0;
    while(i<len&&j<len&&k<len)
    {
        if(s[(i+k)%len]==s[(j+k)%len])
            k++;
        else if(s[(i+k)%len]>s[(j+k)%len])
        {
            i = i+k+1;
            k = 0;
        }
        else 
        {
            j = j+k+1;
            k = 0;
        }
        if(i==j)
            j++;
    }
    return min(i,j);
}
int main()
{
    int n;
    string tmp;
    tmp.reserve(101);
    while(scanf("%d",&n)!=EOF)
    {
        for(int i=0;i<n;i++)
        {
            tmp.clear();
            cin>>str;
            int pos = GetMin(str,str.size()),L = str.size();
            for(int j=pos,cnt=0;cnt<L;j=(j+1)%L,cnt++)
            {
                tmp.push_back(str[j]);
            }
            S.insert(tmp);
        }
        cout<<S.size()<<endl;
        S.clear();
    }
}

 

以上是关于P - How many的主要内容,如果未能解决你的问题,请参考以下文章

How Many Tables HDU - 1213

hdu 1213 How Many Tables(并查集)

hdu 2157 How many ways?? (可达矩阵)

zoj——3557 How Many Sets II

HDU 2138 How many prime numbers

[acwing 308]how many of them题解