1135: 零起点学算法42——多组测试数据(求和)IV
Posted 只想要一个大Offer
tags:
篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了1135: 零起点学算法42——多组测试数据(求和)IV相关的知识,希望对你有一定的参考价值。
1135: 零起点学算法42——多组测试数据(求和)IV
Time Limit: 1 Sec Memory Limit: 64 MB 64bit IO Format: %lldSubmitted: 2439 Accepted: 1277
[Submit][Status][Web Board]
Description
还有一些输入是以上几种情况的组合,具体根据题目对前面几种情况进行组合
比如题目要求是多组测试数据
每组测试数据首先输入一个整数n(如果n=0就表示结束) 然后再输入n个整数
这类题目输入格式如下:
int main()
{
int n,i;
while(scanf("%d",&n)!=EOF && n!=0)
{
for(i=1;i<=n;i++)
{
....//每次输入一个数,共循环n次,需要的时候做其他处理
}
}
}
Input
Input contains multiple test cases. Each test case contains a integer N, and then N integers follow in the same line. A test case starting with 0 terminates the input and this test case is not to be processed.
Output
For each group of input integers you should output their sum in one line, and with one line of output for each line in input.
Sample Input
4 1 2 3 4
5 1 2 3 4 5
0
Sample Output
10
15
Source
1 #include<stdio.h> 2 int main(){ 3 int n; 4 while(scanf("%d",&n)!=EOF&&n!=0){ 5 int a,s=0; 6 for(int i=1;i<=n;i++){ 7 scanf("%d",&a); 8 s+=a; 9 } 10 printf("%d\n",s); 11 } 12 return 0; 13 }
以上是关于1135: 零起点学算法42——多组测试数据(求和)IV的主要内容,如果未能解决你的问题,请参考以下文章