Musical Chairs(约瑟夫环问题)

Posted

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了Musical Chairs(约瑟夫环问题)相关的知识,希望对你有一定的参考价值。

Musical Chairs(约瑟夫环问题)

TimeLimit:1000MS  MemoryLimit:32768KB
64-bit integer IO format:%I64d
Problem Description
In the traditional game of Musical Chairs, N + 1 children run around N chairs (placed in a circle) as long as music is playing. The moment the music stops, children run and try to sit on an available chair. The child still standing leaves the game, a chair is removed, and the game continues with N children. The last child to sit is the winner. 
技术分享

In an attempt to create a similar game on these days‘ game consoles, you modify the game in the following manner: N Children are seated on N chairs arranged around a circle. The chairs are numbered from 1 to N . Your program pre-selects a positive number D . The program starts going in circles counting the children starting with the first chair. Once the count reaches D , that child leaves the game, removing his/her chair. The program starts counting again, beginning with the next chair in the circle. The last child remaining in the circle is the winner. 


For example, consider the game illustrated in the figure above for N = 5 and D = 3 . In the figure, the dot indicates where counting starts and × indicates the child leaving. Starting off, child #3 leaves the game, and counting restarts with child #4. Child #1 is the second child to leave and counting restart with child #2 resulting in child #5 leaving. Child #2 is the last to leave, and child #4 is the winner. Write a program to determine the winning child given both N and D .
Input
Your program will be tested on one or more test cases. Each test case specifies two positive integers N and D on a single line, separated by one or more spaces, where N, D < 1, 000, 000 . 

The last line of the input file contains two 0‘s and is not part of the test cases.
Output
For each test case, write the winner using the following format: 


N D W 


Where N and D are as above, is a space character, and W is the winner of that game.
SampleInput
5 3
7 4
0 0
SampleOutput
5 3 4
7 4 2


就是 约瑟夫 问题咯
code:
#include <cstdio>
using namespace std;
int main( void )
{
    int n, d, f;
    while( scanf( "%d%d", &n, &d ) != EOF && !( n==0 && d==0) ){
        f = 0;
        for( int i=1; i <= n; ++ i ){
            f = (f+d)%i;
        }
        printf( "%d %d %d\n", n, d, f+1 );
    }
    return 0;
}

 

以上是关于Musical Chairs(约瑟夫环问题)的主要内容,如果未能解决你的问题,请参考以下文章

算法:约瑟夫环问题

约瑟夫环问题

约瑟夫环问题

用单向循环链表实现约瑟夫环问题

约瑟夫环问题

约瑟夫环问题