hdu 4707 Pet

Posted ZefengYao

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了hdu 4707 Pet相关的知识,希望对你有一定的参考价值。

                                                                           Pet

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2799    Accepted Submission(s): 1379


Problem Description
One day, Lin Ji wake up in the morning and found that his pethamster escaped. He searched in the room but didn’t find the hamster. He tried to use some cheese to trap the hamster. He put the cheese trap in his room and waited for three days. Nothing but cockroaches was caught. He got the map of the school and foundthat there is no cyclic path and every location in the school can be reached from his room. The trap’s manual mention that the pet will always come back if it still in somewhere nearer than distance D. Your task is to help Lin Ji to find out how many possible locations the hamster may found given the map of the school. Assume that the hamster is still hiding in somewhere in the school and distance between each adjacent locations is always one distance unit.
 

 

Input
The input contains multiple test cases. Thefirst line is a positive integer T (0<T<=10), the number of test cases. For each test cases, the first line has two positive integer N (0<N<=100000) and D(0<D<N), separated by a single space. N is the number of locations in the school and D is the affective distance of the trap. The following N-1lines descripts the map, each has two integer x and y(0<=x,y<N), separated by a single space, meaning that x and y is adjacent in the map. Lin Ji’s room is always at location 0.
 

 

Output
For each test case, outputin a single line the number of possible locations in the school the hamster may be found.
 

 

Sample Input
1 10 2 0 1 0 2 0 3 1 4 1 5 2 6 3 7 4 8 6 9
 

 

Sample Output
2
 
题意:一颗树,每个节点代表一个地方,树的父亲和他的儿子节点的距离为1,给定距离D,要找离根节点大于距离D的所有节点,输出其数量。
思路:乱搞,记录好树的节点信息,层序的遍历即可找到所有距离大于D的节点及数量。
AC代码:
#define _CRT_SECURE_NO_DEPRECATE
#include<iostream>
#include<algorithm>
#include<string>
#include<set>
#include<map>
#include<vector>
#include<queue>
using namespace std;
const int N_MAX = 100000+4;
int N, D;
int num_of_ceng[N_MAX];
vector<int>G[N_MAX];
queue<int>que;
int main() {
    int T;
    scanf("%d",&T);
    while (T--) {
        memset(num_of_ceng, 0, sizeof(num_of_ceng));
        scanf("%d%d",&N,&D);
        for (int i = 0; i < N-1;i++) {
            int a, b;
            scanf("%d%d",&a,&b);
            G[a].push_back(b);
            G[b].push_back(a);//一定要双向记录,题设只是说a和b相邻,没说谁是父亲谁是儿子
        }
        que.push(0);//将根节点压入队列
        int num = 0;
        while (!que.empty()) {
            int father = que.front();
            que.pop();
            for (int i = 0; i < G[father].size(); i++) {
                if (father<G[father][i]) {
                    num_of_ceng[G[father][i]] = num_of_ceng[father] + 1;
                    int num_ceng = num_of_ceng[G[father][i]];
                    if (num_ceng > D)num++;
                    que.push(G[father][i]);
                }
            }
        }
        printf("%d\n", num);
        for (int i = 0; i < N; i++) {//不要忘记清空,以便下次操作
            G[i].clear();
        }
    }
    return 0;
}

 

以上是关于hdu 4707 Pet的主要内容,如果未能解决你的问题,请参考以下文章

报错“Field pet in XXX.HelloController required a bean of type ‘XXX.Pet‘ that could not be found.“(代码片段

#4707. 点分治

使用 C++ 反转句子中的每个单词需要对我的代码片段进行代码优化

HDOJ 4707(模板)

hdoj 4707 BFS

luoguP4707 重返现世